Overclock Pi 3 via config.txt



  • Just been trying to overclock via the config.txt in boot/
    I am having trouble editing the text in it though because it is read only, even after doing mount -o remount,rw /
    using 4.0 beta 6 btw


  • Moderator
    Team

    Just do it through Noobs at boot



  • @davidwrightini Try :
    mount -o remount,rw /boot

    That should do the trick.
    (FYI / and /boot are different partitions : / is system partition while /boot is (you would have guessed it i'm sure) boot partition. By typing mount -o remount,rw / you only allowed Read/Write mode on the system partition while the boot partition remained in Read Only mode which explains why you couldn't save your modifications in the config.txt file as it's stored in boot partition :=)



  • @gkralicek2 Thank you I am just about to try it now.
    Under the overclock section should a just overwrite what is written there with this:
    arm_freq = 1350
    over_voltage = 4
    sdram_freq = 575
    sdram_schmoo = 0x02000020
    over_voltage_sdram_p = 6
    over_voltage_sdram_i = 4
    over_voltage_sdram_c = 4
    core_freq = 500
    v3d_freq = 500
    h264_freq = 333
    gpu_mem = 256
    This was taken from you in another topic.. Thanks!



  • @davidwrightini Yes replace what is in the overclock section with this and it'll work fine !



  • After trying this the method for altering the overclock settings works but recalbox hangs on a black screen upon boot. Maybe it's something I've done wrong


  • Moderator
    Team

    Hello @davidwrightini
    post your config.txt.



  • @davidwrightini Might be caused by the fact your pi doesn't cope well with overclock frequency. Try to lower down the arm_freq parameter in your config.txt to 1250 and see if it boots ok. If so, then increase the value to 1300 and check up if it boots.
    Not all Pi3 behave the same regarding overclock. And adding a small copper heatsink on both your CPU and SDRAM chips might help too (it's strongly advised when pushing frequency over 1300 Mhz and becomes mandatory if you want to reach 1400 Mhz in a stable way)


Log in to reply
 

Want to support us ?

Join us on :

343
Online

25344
Users

13305
Topics

100815
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.