X-Arcade button layout?



  • Is there a description/image of the button layout?

    I'd like to know how to use my buttons. Right now it's not very playable.



  • For the group of six, it's :
    Y X L
    B A R

    Start is on the player button

    As for HK and select, i don't remember, but I personnaly prefer to have HK on the flipper button and select on the left button of the pair below the 6 group. That's to avoid some miss click on HK

    Anyway you can remap that. Also know that, for God knows which reason, the tankstick cantake ages to start, so you may need to restart the buttons mapper later in the boot process



  • I have the Dual Stick and it starts up with no delay. I have not mapped any buttons, it just works in 4.0b5.

    Maybe I should try the mapper, but I had a problem with it earlier. Bought an old Arcade cabinet and had my old X-Arcade controllerboard V1 lying around, and connected that to the original Acade control. Since that had to few buttons I used the mapper to remap to something that kind of worked, and I was using the P2 buttons as well.

    After som modifying I got my X-Arcade stick in the Arcade, and tried to map the buttons, and I was unable to press OK at the bottom. Not with the keyboard, not with the X-Acade or my 360 controller. The only button working was the old but wrong Back button and that just dropped the setup and nothing got remapped.

    In the end I had to reinstall recalbox to get my X-Arcade working.

    Now it works, but I do not like the button layout, and I have not found the buttons.

    What works now is:
    ? = I have no idea if that button does anything

    P1 Start P2 Start
    1 row is X Y ?
    2 row is A B ?
    3 row is ? Select
    Flipper is ?
    P2 rows are the same

    In mame
    P1 Start P2 Start
    Flipper + P1 = Exit emulator
    Select = Coin button
    A = BTN1
    X = BTN2
    Y = BTN3

    In Nes/Snes and any retroarch game
    A&B are swapped. (Why are they swapped?)

    What I would like, is that the 6 buttons would be BTN1 -> 6 in Mame.

    The layout would then be:
    P1 & P2 = P1 & P2 Start
    L&R Flipper = P1 & P2 Select/Coin
    L Flipper= Hotkey
    Row 1: X Y R1 or BTN1 BTN2 BTN3
    Row 2: A B R2 or BTN4 BTN5 BTN6
    Row 3: L1 L2 or BTN7 BTN8



  • the dual arcade has just 1 flipper button. You can map it to both select + hotkey.

    But i strongly do not recommend the layout you mentionned on the top control panel. Rather think of :
    Y X L1
    B A R1
    L2 R2

    Or 6button games like street fighter 2 will be reaaaaaaally messy. But you can have fun with one of those :

    • core remaps (retroarch feature)
    • custom configs (recalbox feature, see the wiki)


  • I usually do not play those... But I see the problem. So in games like SF2 the triggers are not used?
    I'm just thinking of the Xbox 360 controller and with triggers I mean L2 R2.

    I have no problem with your setup, just wondering why you reverse the XY and AB buttons?

    Where do I change the Mame buttons so that I get them in the correct sequence?



  • Yes, only 1 flipper, (just like the Tankstick, the second on the tankstick is a mousebutton).
    I was hoping it would be possible to use the same button as Select/Coin and as a Hotkey.



  • The layout is the one of a SNES pad, not a xbox pad. That's why X/Y and A/B are flipped



  • The layout is inconsistent.

    If I boot Recalbox the button layout is like I configured it.
    If I start a NES or SNES game it works fine.
    When I exit it, it is still the same.

    If I start a NeoGeo or MAME game, when I exit X/Y and A/B are flipped.
    It might be others too, but I have no way of finding that out.

    If I do not start NeoGeo or MAME but just let i stay on for a while, the same thing happens.



  • @Cirion for neogeo, i used the retroarch "core remap feature" tonset a different layout and have the 4 buttons almost "aligned" : the "L2" button + the "B A R1" row



  • And how do I reconfigure when I do not have the button layout? I'm unable to enter the menu and when I try all hell breaks loose. Suddenly I have Sega starting, and I can still hear my old seesion in the background. If I exit the Sega game I'm back in emustation but still I hear the old session in the background. Everything is revered and a reboot is the only thing that works.

    The stupid thing is that I can not find the correct button layout so I can navigate the menus.

    It works with my 360 controller, but I can only configure that one with the 360 controller.

    Last thing that happend now was that suddenly most systems are no longer scraped. I had scraped them all. I did make a backup of the gamelist.xml so I could copy them back in. The problem is WIFI stopped working. I get a configuration error. Same settings as earlier.

    There is something going on with my setup, I can't figure it out, and the button layout is wrong.



  • I received a Xin-Mo adapter in the mail yesterday. Maybe I should just use that for the X-Arcade and order a new one for my kabinet. The buttons and sticks have not arrived.



  • Does your controller get reversed if you enter Neo-Geo Metal Slug and exit?



  • I guess you can't determine if the xarcade driver started. Let me sum it up : the xarcade is a keyboard emulator. Recalbox doesn't handle keyboards. BUT ES and some emulators can handle keyboards against "recalbox' will".

    So, i really recomment you do start the driver late in the process like i do, by editing ~/custom.sh and adding the launch from there. Do you need some.more help to do that ?



  • I know how to edit files, but I need help with what to write in the custom.sh to launch the driver.

    I started with a fresh 8GB SD class 10 card, since I am now using a 250GB USB HD.
    I figured out why the games where no longer scraped, and it is due to a write error so the gamelist.xml files where corrupt.
    I had all but 1 in my backup so they are back and working. I have to be better at shutting down instead of pulling the power.

    Wifi is also working now.

    I have not changed the layout of the X-Arcade this time, and out of the box a/b and x/y are swapped after starting a NeoGeo or Mame game. And they stay swapped until reboot.

    This does not happen when starting NES or SNES games.



  • your custom.sh can just have :

    /usr/bin/xarcade2jstick &
    

    also read https://forum.recalbox.com/post/32135 for the rest


Log in to reply
 

Want to support us ?

Join us on :

372
Online

29847
Users

14893
Topics

112151
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.