Problema al cargar juego



  • Buenas noches a todos,
    hace días estuve probando todos los juegos de recalbox y funcionaban perfectamente. La he vuelto a poner en funcionamiento hoy y al seleccionar cualquier juego no me carga, aparece la pantalla negra de cargando y vuelve al menu principal.

    ¿Alguien sabe porque puede ser?
    Gracias amigos


  • Moderator
    Team
    Moderator
    Translator

    @beita la pregunta puede ser tonta, pero... Has hecho algun cambio en recalbox desde cuando "funcionaba" hasta ahora? Conectarlo a otro tipo de monitor o cambiado la configuracion de video?



  • @paradadf mismo monitor y no he tocado nada. Active la opción de mandos virtuales en recalboz.conf pero después de eso también estuve jugando.


  • Moderator
    Team
    Moderator
    Translator

    Como esta conectada tu Raspberry al monitor?
    Echale un vistazo a la wiki, quiza te ayude.
    https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN)

    Algo tuvo que haber cambiado, la pregunta es que?!


  • Moderator
    Team
    Moderator
    Translator

    Si no encontras respuesta con eso, vamos a necesitar esto:
    https://github.com/recalbox/recalbox-os/wiki/Recalbox-support-(EN)



  • @paradadf mediante un conversor del JACK de la raspberry a VGA, ya que la pantalla es un monitor de los antiguos, 4:3, pero ya toque tanto el archivo config.txt y recalbox.conf


  • Moderator
    Team
    Moderator
    Translator

    @beita ok, necesito el archivo generado despues de ejecutar este comando:
    /recalbox/scripts/recalbox-support.sh
    Como indica el ultimo enlace que te escribi.



  • Ya lo tengo! Pero me dice que no tengo privilegios para subir nada :(




  • Moderator
    Team
    Moderator
    Translator



  • @beita Muy buenas, tengo el mismo problema que tu. ayer de puta madre, hoy la enciendo, y nada de nada. pudiste solucionarlo?



  • Hola, jejeje hace tiempo que no me meto a marear la perdiz jajajaja. Bueno paradadf te dare la alegria de que esta vez me pare a mirar pacientemente si algun tema coincidia con mi problema y enefecto este es el tema que mejor encaja con mi problema. Bueno pues que estoy en la misma tesitura, de ir todos los juegos perfectamente a derrepente no ir ni un emulador, ni el cavestory funciona y todo fue a raiz de que cambie dos lineas en un archivo de la carpeta boot/, el llamado config.txt. Esas dos lineas que modifique eran disable_oversan: 0 (cambiado a 1) y una linea que aparecia al final bajo el apartado de la configuracion de NOOBS. Hice esto porque no me ajustaba correctamente la pantalla completa ni el emulationstation ni los juegos. Sin embargo ahora el problema es mucho peor y es que, ahora no me carga ni un juego de ningun emulador. Porque luego, toque otro archivo de la carpeta de scripts/, el llamado retroarch.cfg. Toque este archivo porque queria ver porque no se guardaban los cambios que hacia en el menu de retroarch tras iniciar un juego. Pero solo le cambie el apartado de video_interger_scale: <true> que lo que hice fue pasarlo a <false> con la idea de que ese valor me ajustara los juegos correctamente a la pantalla completa a pesar de la deformacion visual que eso conllevara. Buen o pues el resultado, un desastre vaya. Estoy dejandome asesorar por los usuarios del irc de recalbox. Pero me cuesta un poco formular las cosas en ingles. Por lo que escribo aqui con este problema por si puedo recibir alguna solucion en español. Gracias.


  • Moderator
    Team
    Moderator
    Translator

    @fullskull jajajja yo ayudo en lo que puedo!
    Que te dijeron en irc? No intestaste volver todo a la normalidad a ver si el problema se solucionaba?
    El overscan y el ajuste de la pantalla lo podes activar/ajustar desde el mismo ES... no entiendo para que se van siempre por lo mas complicado. En ajustes de interfaz (UI settings) si mal no recuerdo la primer opcion es el overscan y la segunda deberia decir algo referente a la relacion de aspecto y estar en AUTO. Esa podes cambiarla por 16:9, 4:3, etc. Ademas la opcion de pixel perfect tiene que estar obviamente desacticada. Siempre hay la posibilidad de que los archivos del sistema se hayan corrompido por alguna falla de, por ejemplo, el suministro de voltaje. O que cambiando alguna configuracion sin saber hayas esteopeado el sistema :)



  • Hola paradadf, pues he estado tratando en chat irc con un usuario y bueno, me ha dado una pauta en caso de eso pudiera corregir el error. Pero que va, al final no funciono. El caso es que intentase, por ejemplo de una carpeta de roms, extraerle el gamelist.xml (respaldarlo) y reiniciar el Recalbox, para que este lo volviese a crear, pues penso que podria ser un problema en relacion a tema de los scrapes y las rutas del gamelist. Pero no, no surtio efecto alguno. En el proceso si me ha hecho que ejecutara una serie de comandos desde ssh, con el objetivo de sacar un log, de porque la falla al ejecutar los juegos. Bien esto es lo que reporto mi recalbox: https://thepb.in/p/NxhVYpqj1l9hN. Haber, si la cosa no tiene solucion, me tocara hacer un respaldo y hacer un hard reset de Recalbox. Pero si pudiera ahorrarmelo y poder localizar el problema. Yo creo que tiene que ver con retroarch, porque aun cambiando el nucleo y el emulador en los ajustes de juego, sigue de la misma guisa. Entonces habria que ver como restaurar la configuracion de retroarch o actualizarlo o incluir algun archivo o algo. No se.


  • Moderator
    Team
    Moderator
    Translator

    @fullskull tu log no dice nada fuera de lo normal. La verdad es que no tengo ni idea que te ha pasado. A reinstalar sera, lo siento.
    Aunque si le has dado 'save on exit' en retroarch se crea por algun (imagino que share/system...) un retroarch.custom.cfg (o algo asi). Podrias intentar desactivar el guardado y borrar ese archivo, despues reiniciar. Asi deberia volver a usar el original.



  • Vale a ver, de momento lo de reinstalar no va a ser necesario. En principio trasteando, he visto el origen del problema, sin embargo aun tengo problemas de emulacion con algunos emuladores. Bien, el archivo llamado "emulatorlauncher.sh" (alojado en recabox/scripts) era el que por alguna razon hacia que ningun emulador corriese ningun juego y mostrase la pantalla negra. Posiblemente se corrompio al tratar de sobreescribirlo desde filezilla cuando queria subirle una version de si mismo, con una linea modificada. Tras bajarme un programa para tratar de gestionar los archivos de linux generados en RECALBOX desde windows, localice ese archivo que respalde como original y lo he vuelto a restaurar y ahora los emuladores si emulan correctamente o alguno de ellos. Pero el motivo por el que digo que mi problema aun no esta solucionado es porque, por ejemplo, el emulador de megadrive no corre ni un juego a pesar de cambiarle el emulador y el nucleo y el CAVE story tengo un problema derrepente muy extraño (cuando antes iba perfecto) y es que la emulacion da como "saltos" y pareciera que el personaje se teletransporta a su antojo cada 1-2 segundos. Y aqui creo que el problema lo tengo con la configuracion de retroarch y los nucleos y los ajustes preestablecidos o algo, pero bueno son supuestos no se si es por eso o porque. Tratare tambien con los de IRC de Recalbox a ver si saco algo en claro y si logro por ahi solucionarlo os digo algo por aqui. Un saludo.



  • Hola de nuevo, deciros que ya he podido arreglar el problema. Al final he hecho quizá lo mas simple pero a la par menos pensado. He hecho una instalación nueva en otra tarjeta mini SD de tal manera que de esa nueva instalación, los archivos de sistema y configuración, me sirviesen para reemplazar, los que tenia en mi respaldo. Y aunque al hacerlo solo se ha visto borradas las configuraciones de la interfaz, como la conexión de wifi o el idioma, lo demás, todos los emuladores, responden a la perfeccion. Decir que para este proceso solo he tenido que echar mano de un programa para instalar en Windows y asi hacer la gestión adecuadamente entre el sistema de archivos de cada sd que RECALBOX genera y que no son visibles por el sistema operativo. Este programa (que lo recomiendo encarecidamente para estas gestiones) se llama "Paragon ExtFS for Windows" y lo que hace una vez instalado y ejecutado, es que detecta las particiones ext4 y las traduce o las visualiza en Windows, para que tengamos acceso a ellas. En este caso nos mostraría 4 carpetas: RECOVERY, SETTINGS, root y share. Yo en principio de la nueva instalación he cogido los archivos que mas se identificaban con las configuraciones por defecto tanto del EMULATIONSTATION como de RETROARCH y las he reemplazado en el respaldo del sistema que tenia el problema. Para ser mas concretos, dentro de la carpeta "share/system" he ido cogiendo de manera selectiva archivos de varias carpetas y las he ido arrastrando y sobreescribiendo del respaldo. Una vez cogiendo los archivos y habiéndolos sobreescrito, con el nuevo reespaldo (digo nuevo por los cambios que se han hecho) los he volcado a la tarjeta donde tenia elproblema y !voala¡ problema solucionado. Decir que si se va a hacer una prueba de este método, previamente instalar el programa que señalo para Windows y hacer un respaldo de la tarjeta que tiene el problema y tener a mano otra para llevar a cabo esto, porque no aconsejo toquetear si no se tiene experiencia ni sin saber lo que se hace sin tener un respaldo hecho. Bueno espero que esto pueda servir de ayuda, para problemas de cargas de juego con pantalla negra y juegos que se cargan bien pero sin audio y/o modificaciones erróneas en líneas de archivo del sistema. Un saludo.


Log in to reply
 

Want to support us ?

Join us on :

311
Online

31258
Users

15144
Topics

113903
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.