Moonlight not pairing



  • Hi,
    I followed all instructions given on this site: https://github.com/recalbox/recalbox-os/wiki/Setup-moonlight-(EN)
    I applied configuration "a" (Version >= 4.0.0 beta1).
    After using the command "./Moonlight.sh pair" I get this "error" message:

    Moonlight Embedded 2.2.0 (EMBEDDED;CEC;PI)
    Too many options: No such file or directory
    Moonlight Embedded 2.2.0 (EMBEDDED;CEC;PI)
    Searching for server...

    I also tried to delete /recalbox/share/system/configs/moonlight/keydir but without succes.

    My PC is connected via LAN and my Raspberry PI3 via Wifi repeater.
    What did I do wrong?


  • Moderator
    Team

    Hello
    version of recalbox ?



  • I am pretty shure im using 4.0.0 -beta 5.
    I updated it yesterday.


  • Moderator
    Team

    @subs can help you.



  • @nik14 Are you sure both your pi and PC are on the same sub LAN ?



  • Where can I check that?



  • I'd say your Wireless AP creates a subnet ... Check your ips from your PC and recalbox. I'm pretty sure they are not in the same subnet ... As this also depends on the mask, just give me the IP and mask of both your pi and recalbox, and i'll tell you



  • The version of GFE on my PC is 2.11.4.0



  • I just realized that although it says that I am GameStream Ready the checkbox for the Router is not green.
    Can that be the problem or does it just mean the GameStream will be very lagy?

    0_1471949796357_Unbenannt.png



  • @nik14 can you try to run avahi-browse -prt "_nvstream._tcp" from a shell on your pi ? It should return your PC.
    The router thing is just for better wireless connectivity, shouldn't be important

    Have you logged in to nvidia ? tried to clear paired devices ?



  • 0_1471962518583_Unbenannt.png

    I am logged into Nvidia and never paired any devices before, but cleared them now anyway.



  • dunno if you already successfully paired before, but try running /recalbox/scripts/moonlight/Moonlight.sh clean and then pair again
    Your screen shows that your PC does advertise its gamestream capabilities. Why not try setting an IP in the Moonlight.sh?



  • After running /recalbox/scripts/moonlight/Moonlight.sh clean it worked!!!
    Thank you!


Log in to reply
 

Want to support us ?

Join us on :

261
Online

31120
Users

15122
Topics

113784
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.