Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

Updating recalbox 4.0.0 beta (2016/2/25) to newest beta



  • Hi there,

    I am having the problem that my recalbox won't do the update. Download progress seems to hang after executing upgrade script. In addition, ssh is not responding after reaching that status.

    Any ideas?

    # sudo /recalbox/scripts/recalbox-upgrade.sh
    -sh: sudo: command not found
    # /recalbox/scripts/recalbox-upgrade.sh
    --2016-07-30 08:40:02--  http://archive.recalbox.com/4/rpi2-unstable/stable/last/boot.tar.xz
    Resolving archive.recalbox.com... 37.187.92.30
    Connecting to archive.recalbox.com|37.187.92.30|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 5342624 (5.1M) [application/octet-stream]
    Saving to: '/recalbox/share/system/upgrade/boot.tar.xz.part'
    
    /recalbox/share/system/ 100%[=============================>]   5.09M  2.63MB/s    in 1.9s    
    
    2016-07-30 08:40:04 (2.63 MB/s) - '/recalbox/share/system/upgrade/boot.tar.xz.part' saved [5342624/5342624]
    
    --2016-07-30 08:40:04--  http://archive.recalbox.com/4/rpi2-unstable/stable/last/root.tar.xz
    Resolving archive.recalbox.com... 37.187.92.30
    Connecting to archive.recalbox.com|37.187.92.30|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 162298292 (155M) [application/octet-stream]
    Saving to: '/recalbox/share/system/upgrade/root.tar.xz.part'
    
    box/share/system/upgrad  26%[======>                       ]  40.49M  2.51MB/s    eta 52s    
    


  • The update is made in 2 steps :

    • download (that's what you're doing)
    • reboot to apply the update

    The download shouldn't hang. Do you have enough space left ?



  • Tried to delete the temporary files in folder upgrade and executed the script again. Unfortunately without success. The upgrade process can be seen shortly and then recalbox restarts again with the old version.

    Here is the upgrade error log

    cp: can't stat 'recalbox-boot.conf': No such file or directory

    And it seems to be right that there might be a disc space problem: The GUI says "0GB/13GB". /dev/Root/ has 150MB free disk space left.
    How can I delete unnecessary files? Roms are nearly none existent ...



  • What does df -h report ?



  • here you go:

    # df -h
    Filesystem                Size      Used Available Use% Mounted on
    /dev/root               979.6M    762.1M    150.9M  83% /
    devtmpfs                236.9M         0    236.9M   0% /dev
    tmpfs                   241.1M         0    241.1M   0% /dev/shm
    tmpfs                   241.1M      4.0K    241.1M   0% /tmp
    tmpfs                   241.1M      2.4M    238.7M   1% /var
    tmpfs                   241.1M    164.0K    240.9M   0% /run
    /dev/mmcblk0p1           63.0M      6.6M     56.4M  10% /boot
    /dev/mmcblk0p3           13.4G    234.8M     12.5G   2% /recalbox/share
    # 
    


  • Does anyone have an idea?



  • cp: can't stat 'recalbox-boot.conf': No such file or directory

    recalbox don't find your /boot/recalbox-boot.conf file. Some old, 4.0.0 alpha versions didn't had this files.

    Try to create it manually, then retry an update :

    • to remount /boot partition with write rights :
      mount -o remount, rw /boot

    • then this command to create the file :
      echo -e "internal=/dev/mmcblk0p3\nsharedevice=INTERNAL" > /boot/recalbox-boot.conf

    Now try to update the system using the /recalbox/scripts/recalbox-upgrade.sh script.



  • @rockaddicted said in Updating recalbox 4.0.0 beta (2016/2/25) to newest beta:

    /recalbox/scripts/recalbox-upgrade.sh script.

    Work like a charm! Many thanks to you @rockaddicted



  • you are welcome 😉



Want to support us ?

348
Online

79.7k
Users

21.1k
Topics

154.4k
Posts