Recalbox 7.0

XArcade Tankstick Issues



  • I'm having issues getting my new tankstick working with Recalbox.  I have the setting correct in the configuration file (controllers.xarcade.enabled=1) but it still treats the Tankstick as a keyboard.  I looked at the log file and get this message: 3.60] : xarcade2jstick : no official stick found, looking for keyboard encoder now ...   I'm not sure if I'm just missing a step as I didn't see that there was anything other steps I needed to take to enable this service.  I'm on the most current version of recalbox and don't believe it's an issue with the tankstick as it worked in a Retropie image I was using prior to this.  Thanks for any help!



  • Hi @stratman95 It happens the tankstick isn't yet "available" from the OS point of view when the xarcade2jstick is started. I have the problem myself SSH to your recalbox, do the following : touch custom.sh chmod u+x custom.sh Edit custom.sh and add : /usr/bin/xarcade2jstick & That script is the last one started, so you may have to wait a little until it's recognised



  • I just tried your fix and it appears to be working correctly now.  The button mapping seems a little off, but that is an easy fix.  Thanks for your help!



  • the button mapping is made on my experience : the 2 lower buttons can easily be pressed by mistake. So, when playing you could combo HK+A and ... reset your game ... so HK is on a flipper button, select is on the right of those 2 buttons, and start is ... well, no need to say 🙂



Want to support us ?

178
Online

79.1k
Users

20.4k
Topics

149.3k
Posts