[Solved]Recalbox change screen resolution using Hdmi to DVI cable



  • Hello everyone. First, sorry my bad english. I have a big problem with recalbox from days ago I can´t solve it. I´m making my own Bartop and I´m using 19" LCD screen with hdmi to DVI-D cable converter. The resolution of the screen works fine when Raspberry boot (I try many resolutions changing config.txt and works). The problem is, when  Recalbox is launching after the boot, for some reason the resolution change automatically and screen can´t recognize it. I try in 3 diferens LCD´s and the problem is the same, the screens is showing noise and screen displacement (in one of the 3 lcds the screen just turn black trying auto resolutions every few seconds). I try in this same LCDs Retropie and screen works perfect (up to 1280x1024). By the way, I try global.videomode=default in recalbox.conf and not working. Hope can help me. Thank you very much in advance.


  • Staff
    Global moderator
    Team

    Hello in ssh or with winscp

    mount -o remount,rw /boot
    

    Edit file : /boot/config.txt, add #symbole before hdmi_drive=2 like this : #hdmi_drive=2 tuto : https://github.com/recalbox/recalbox-os/wiki/Connect-your-recalbox-to-a-DVI-screen-(EN) You can use tv service -m DMT or global.videomode=defaultin recalbox.conf tuto : https://github.com/recalbox/recalbox-os/wiki/Video-configuration-detailled-(EN) Exemple : my screen 19" LCD : tv servce -m DMT -> (prefer) mode 35: 1280x1024 @ 60Hz 5:4, clock:108MHz progressive in recalbox.conf , I ADD this : global.videomode=DMT 35 HDMI and in recalbox.conf, modified ratio

    ## Set ratio for all emulators (auto,4/3,16/9,16/10,custom)
    global.ratio=custom
    

    save and reboot raspberry I have no problem : RPI2 / RPI3 - RECALBOX 4.0.0b3 unstable mode - LCD 19" 1280x1024 (5/4 ratio)



  • Hello Acris. Finally this works! Thanks a lot! I´m noob in Linux, so I don´t know how exactly work the remount command (I not found this advice before in any config tutorial). For anyone, I repeat the steps I realize it as you say: 1- I connect the Raspberry Pi to my network an access via Putty. 2- I write  mount -o remount,rw /boot using Putty for Windows. 3- Open boot/config.txt file with WinSCP and comment hdmi_drive=2 line with # symbol (#hdmi_drive=2). 4- Open in recalbox.conf and write global.videomode=default 5- Save, turn off RPi, connect to my CRT and Reboot. Using HDMI to DVI-D cable in 19" monitor with 1280x1024 60hz



Want to support us ?

386
Online

81.4k
Users

22.3k
Topics

161.5k
Posts