N64 sound but no video



  • Just wanted to check the same issue on v3.2.9 is being experienced where with the N64 emulation the screen goes black after starting a game? Or have I missed something?


  • Staff
    Developer
    Global moderator
    Team

    Hi @nickdj N64 is broken for now, i will work on that for 3.3.0



  • Many thanks and keep up the excellent work. I've shown several people how good Recalbox is and they've all decided to buy a Raspberry Pi 2 specifically to use it. A testament to how good Recalbox is and your hard work.



  • I was also having this issue when trying to run Mario Kart 64 but I got a different rom and it video worked fine. I did have a problem though with the B key on my SNES USB controller exiting the emulator during gameplay...not sure why but it's not playable because of this but just wanted to let you know! Nice work..this is my first Pi and I went straight to this to get emulators+xbmc. Bravo.



  • Thanks to all for posting this issue, I thought I did something, lol.



  • I got it working again:

    1) press F4 to quit emulationstation
    2) press ALT+F2 to show command
    3) login with user "root" and password "recalboxroot"
    4) enter: "cd ../recalbox/scripts"
    5) enter: "nano emulatorlauncher.sh" to start editing the file
    6) scroll all the way down and change the "4" in "2" at this line:
    "if [[ "$emulator" == "n64" ]]; then
    "/recalbox/scripts/runcommand.sh 4 "SDL_VIDEO_GL_DRIVER=/usr/lib/libGLESv2.so mupen64plus --corel..."
    7) press CTRL+X to quit the editor and press "Y" to save the file
    8) enter: "reboot" to restart the pi.


  • Ewout, I tried your fix, with not the same results. I found the line you referenced, except my setting was not 2 but 3. I changed it to 4 anyway with no positive results. Sorry I could replicate your success. Kryptto



    1. scroll all the way down and change the "4" in "2" at this line: --- @kryptto I think you have to change your 3 into a 2 and not into a 4. @ewout Thanks for the fix, it is working now.


  • retrojunkie, Thanks I should of tried that. Changing it to '2' worked. Thanks!



  • Thanks for this information. This worked for me although the sound is broken and game laggy. I'm guessing the Raspberry Pi 2 isn't quite up to the job? I might have to overclock?



  • Nickdj, I agree though many of the games now started working my RPI2 is very choppy and audio is broken up. This wasn't a perfect fix. I am awaiting the 3.3.0 release. Kryptto



  • To be honest when the N64 emulation was working with video (3.2.4 I think) the results were the same. Still yet to be able to play the Zelda games on the RPi2. I can't wait for 3.3.0 and I'm checking several times a day. 🙂 Very happy with FBA and PSX emulation but N64 needs a little work. When someone works out how to get controllers working with Kodi I'll be very happy.


Log in to reply
 

Want to support us ?

254
Online

81.4k
Users

22.2k
Topics

161.4k
Posts