Screen goes black after install&reboot [solved]



  • Hi, i have an RPi1 and unpacked the RecalBoxOS 3.2.9 release to its SD card. I booted the RPi and installed the RecalBoxOS. Now, if i boot the RPi, after the initial "hold Shift for recovery mode" screen, all i get is a black screen. Whats going wrong here? Thanks, beetle PS: SD card is 16GB SDHC, after installer worked i get 4 partitions on it, all is looking sane, config file in correct folder etc. Screen is Sony TV with HDMI cable.



  • Did you use the SD card formatting tool?


  • Team

    Try to remove the hdmi_drive line in config.txt. See the mini howto on the wiki, you'll have guides for that.



  • I formated the SD card using gparted (debian linux) 1 primary partition , maximum size, fat32 then unplugged/plugged SD card, partition got automounted, then i unzipped contents of latest RecalboxOS archive to it. Put into RPi and booted. FAT got rezised and configured automagically. I selected the RecalBoxOS and pressed (i) to install. Installation was ended successfully. Will try to comment the line hdmi_drive.



  • i tried to remove the line "hdmi_drive=2 " in /boot/config.txt (using noobs editor of recovery mode) but no change. I played around with the other settings, like hdmi_safe=1 and was even uncommenting the hdmi_group=1 and putting hdmi_mode=4 to force a different mode, but there was absolutely no change. Not even the noobs screen differed. I think RecalboxOS doesn't find the config.txt This is the Partition scheme i get after (successful!) install to my 16GB SDHC card: (its /dev/sdc in my PCs card reader) /dev/sdc1 primary FAT32 RECOVERY /dev/sdc2 extended /dev/sdc5 FAT32 boot /dev/sdc6 ext4 root /dev/sdc7 FAT32 share /dev/sdc3 primary ext4 SETTINGS Is that as expected?



  • I had the same issue and just by adding a hash before hdmi_drive=2 worked for me (i.e. #hdmi_drive=2). This allowed me to use a computer monitor, however, it's still works fine on my TV as well. :-)


  • Team

    Try to remove all hdmi_* options in config.txt (you are editing the config.txt of the boot partition right ?) and just set hdmi_safe to see what happens. Your partitions are ok. So what you can do next : try it on an other tv to see if it boots. If you can't then try to connect your rpi to your network with an ethernet cable and see if it appears on it. What we want to know is if it boot or if it hangs on boot. Last thing will be to test an other SD card.



  • I tried hdmi_safe and disabling all other stuff, then tried another screen but same issue. Finally i tried my 8GB SD card instead of the 16GB one - and it works right out of the box (read: archive). Is there a database of working/non working SD cards? If not, do we want to start one? Thanks @ all. Will now try playing some games :) Beetle



  • http://elinux.org/RPi_SD_cards This is the link to the compatible SD cards on the Raspberry Pi. I did buy the 64GB Transcend card but it didn't work. If your Raspberry Pi doesn't boot when you write the files to it using Windows, check it's formatted as FAT32 and as a Primary rather than logical partition. I used MiniTool Partition Wizard to achieve this. (http://www.partitionwizard.com/free-partition-manager.html) The one in my signature was £25 and reads at over 90MBs so highly recomend it! http://www.mymemory.co.uk/Micro-SDXC/Kingston/Kingston-64GB-Micro-SDXC-Card-Class-10-UHS-I-U1-90-MB_s


Log in to reply
 

Want to support us ?

Join us on :

329
Online

31057
Users

15114
Topics

113730
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.