Configuration manette Super Street Fighter 2 Turbo sur Mame



  • Bonjour à tous !

    Un ami m'a refilé sa recalbox 7.0 sur raspberry Pi 4, avec une pléthore de jeux à plus savoir qu'en faire.
    Problème : Il ne m'a absolument rien expliqué de son fonctionnement, et il est indisponible...
    Donc, voici l'un de mes (nombreux) problèmes :
    J'essaie de jouer à super street fighter II turbo sur mame, mais impossible de configurer ses touches, car ce jeu d'arcade n'a tout simplement pas de menu d'options.
    Néanmoins, in game, lorsque j'appuie sur le stick gauche de ma manette (une réplique de manette snes avec des joysticks et 4 boutons sur la tranche), j'accède à un menu qui propose des options, dont celles-ci :

    • input (general)
    • input (this game)

    Mais quand je vais dans input (this game), je n'arrive pas à changer les touches, ça ne donne rien.
    Je précise que je ne souhaite changer les touches que pour ce jeu, pas pour les autres.
    Je précise aussi que je suis très loin d'être une flèche en bidouillage informatique, alors faudra m'expliquer lentement, parce que je suis foutu de faire une connerie que je saurais pas réparer.

    Suis-je dans le bon menu ?
    Si oui, comment changer les touches sans tout détraquer ?
    Si non, comment faire ?
    Et même, peut-on le faire, tout simplement ?

    Merci infiniment et par avance à ceux qui prendront la peine de répondre...


  • Theme moderator
    Themer

    Personnellement, je passe par le menu retroarch
    HOTKEY + B
    Puis dans le menu correspondant (Touches) je règle mes boutons comme je veux (port 1 touches) je sauvegarde uniquement pour ce jeu (sauvegarder le remappage uniquement que pour ce jeu) ainsi les autres restent tel quel.
    Et quand je le relance ça reprend ma configuration de boutons que pour ce jeu
    L'image ci dessous viens de retroarch version Android mais peu importe c'est la même chose.
    Screenshot_20210227_202829_com.retroarch.aarch64.jpg



  • Merci infiniment camarade !

    Effectivement, ça marche.
    Je comprends pas pourquoi j'étais passé à côté...


  • Theme moderator
    Themer

    Quand on commence, on sait jamais ou chercher, il y a tellement de paramètres que l'on peut affiner a ses goûts !


  • Theme moderator
    Themer

    en fonction de la version du jeu SF2, tu peux aussi ajuster la difficulté ( que je trouve trop élevée pour moi 😕 )
    Ca dépendra donc du jeu :

    • rester appuyer sur "start" quelques secondes d'affilées pour entrer dans le menu des options du jeu
      ou
    • Menu retroarch (Hotkey + B), aller dans le menu "Option" et choisir la difficulté, la vitesse du jeu etc...


  • Ah merci, ça peut être utile, en effet.
    Pour la difficulté, ça va. J'ai un peu perdu de mon talent d'autrefois, mais ça revient petit à petit.
    Les combos et les 360 sont encore un peu laborieux, mais ça ira.
    Par contre, un truc casse-c******es, c'est la taille de l'écran ridicule sur les versions arcade.
    Y aurait pas moyen de remettre ça un peu plus gros, histoire que la taille de l'écran de la borne touche les bords de mon écran ??

    Par contre, la machine ne veut plus démarrer aujourd'hui...
    J'ai touché les options, et depuis, c'est la merde !!
    J'ai posté un autre sujet dans le forum, et je suis un peu inquiet, je te cache pas.

    Trois jours que je l'ai et déjà deux fois dans la panade.
    Ca promet...


  • CRT Hero

    @zoutroy said in Configuration manette Super Street Fighter 2 Turbo sur Mame:

    Par contre, un truc casse-c******es, c'est la taille de l'écran ridicule sur les versions arcade.
    Y aurait pas moyen de remettre ça un peu plus gros, histoire que la taille de l'écran de la borne touche les bords de mon écran ??

    Tu parles probablement de l'integer scaling, il est possible de le désactiver, par contre çà entraîne des déformations au niveau des pixels.



  • Ok, c'est dommage parce que l'interface est vraiment petite sur certains jeux, on aimerait l'avoir plus grand.
    Mais bon, j'ai souvent 4 ou 5 versions d'un même jeu sur 4 ou 5 machines différentes, donc je peux toujours changer de version.
    Bref, vu les soucis que j'ai déjà, je pense que si j'arrive à la refaire marcher, je touche plus à rien, c'est officiel !!


  • CRT Hero

    @zoutroy said in Configuration manette Super Street Fighter 2 Turbo sur Mame:

    Ok, c'est dommage parce que l'interface est vraiment petite sur certains jeux, on aimerait l'avoir plus grand.

    Si tu veux de la lecture, c'est l'un des articles les mieux expliqués que j'ai trouvé sur le sujet : https://tanalin.com/en/articles/integer-scaling/

    Encore une fois, c'est possible de le désactiver (direct dans la config recalbox je crois, mais je ne sais plus où, sinon dans les réglages vidéos de retroarch), mais tu t'exposes à plein d'effets secondaires sur les pixels (il y a des joueurs que çà ne dérange pas).



  • Quand j'arriverai à comprendre correctement comment marche la machine, je tenterai des trucs dans ce genre.
    Pour l'instant, j'ai été UNE fois faire un tour dans les options, et depuis, la bécane ne démarre plus.
    Donc, si elle remarche un jour, j'y touche plus avant de savoir ce que je fais, et tant pis pour les petits écrans et les gros pixels ^^


  • Global moderator
    Global moderator
    Tester

    @zoutroy Je t'ai répondu sur l'autre post.
    Par contre, je te conseille d'activer/désactiver tes options 1 par 1 afin de savoir remettre facilement ce qui ne va pas/ne te convient pas.
    Fais tes tests avec parcimonie et tempérance 😁



  • Ca, tu peux en être sûr !
    je crois que je vais plus rien toucher du tout, oui !


  • Theme moderator
    Themer

    Si t'as foiré un réglage efface le fichier retroarch.conf je sais plus où il est par contre mais il se retrouve facilement.
    Si ca reprend toujours pas je te donnerai une autre astuce

    Pour le plein écran, ça dépend de la TV (720 ou 1080?)
    En 720 le pixel perfect est proche du plein écran pour ma majorité des résolutions car c'est juste une résolution multiplié par 3.
    En 1080 le multiplié par 4 ne marche pas donc ça reste à multiplier par 3 mais tu perds de la surface.
    Astuces donc, forcer le 720, et garder le pixel perfect. Ou rester en 1080 et activer le lissage des jeux, mais supprimant le pixel perfect et autres shader.


  • Theme moderator
    Themer

    Personnelement j'ai fait le choix de forcer le 720 pour garder le pixel perfect et mon shader préféré (crt-nes-mini)

    Dans le cas du 1080, le lissage des jeux permet de "gommer" les defauts liés au fait de ne plus etre en pixel perfect (pour avoir toute la hauteur de l'ecran, de bas en haut, utilisé pour les jeux) l'image sera ainsi plus homogène avec le lissage qui supprimera cet effet d'escalier. (il y a des alternance entre des ligne a 3 pixels de large et de 4 pixels de large, créant des sortes d'escaliers légèrement visible sur du scrolling sans le pixel perfect, mais qui n'est plus visible avec le lissage des jeux)

    bon pour ton probleme de démarrage je t'ai répondu aussi sur l'autre fil, j'espere que tu vas réussir à reprendre et pouvoir redemarrer à nouveau ton systeme.



Want to support us ?

226
Online

82.6k
Users

22.8k
Topics

164.4k
Posts