Mame - Splatterhouse? Anyone get to work?



  • I have ran clrmame - tried every iteration of rom I can find for this game and cannot get it to work! Has anyone else been successful in running this game? I need help.


  • Themer

    No it doesn't work on mame neither fba libretro on the pi. I recommend to avoid using clrmamepro when you have that kind of problem, better try to find the correct romsets. Also, you can play Splatterhouse on PCEngine I think



  • I'm more interested in the arcade version as I used to have the PCB and miss it.


  • CRT Maniac

    Splatter House Arcade (splatter.zip) works with iMAME4All. But doesn't work with Mame2003 and FBA. I just try it and play.



  • Hi, Splatterhouse is also one of my favorite games (i used to play the Japanese PC-Engine version). I really want to play the arcade version, but cannot manage to get it work. I tried to update the recalbox.conf file like below : ## Mame emulator ;mame.emulator=libretro mame.core=imame4all then i tried several version of splatterhouse (splatter.zip and splatterj.zip) but still cannot launch it. I always get a black screen before getting back to the Mame menu. I used to play other games flawlessly using Mame. Am i wrong somewhere in the configuration ? PS : i'm using a raspberry PI 2B, with the latest distribution of recalbox (v 4.0.0 beta 2) many thanks in advance for your help, Jeff


  • CRT Maniac

    Hi I’m using a raspberry PI 2B, with recalbox (v 3.0.0 beta 17) I use iMame4ll LibRetro and Splatter House Arcade version works perfectly. Look your private message.



  • Hi Ironic, Thank you for your reply. So i tried this, i can go further (i have the legal screen where you have to do left-right with the stick, then i have a second screen with some technical informations of the game) but then i have a black screen after pressing a button or moving the stick. From there i need to restart the raspberry as i'm not able to exit normally. I may have something else missing ... I only modified the recalbox.conf, using mame.core=imame4all I'm sorry but i'm new to recalbox ... Kind regards, Jerome


  • CRT Maniac

    Arf, i don't know why your Splatter House Rom doesn't work. It's a standalone rom (no need BIOS file)   Try this : ## Mame emulator mame.emulator=libretro mame.core=imame4all I use Recalbox 3.0.0b17 and i don't know if it works on 4.0.0b2 I will try... I tell you soon


  • Moderator
    Team

    Hello sorry for my english. Check if game is good romset : imame4all - romset 0.37b5 (July 2000) mame2003 - romset : 0.78 (December 2003) https://github.com/recalbox/recalbox-os/wiki/Easy-Arcade-on-Recalbox-(EN) https://github.com/recalbox/recalbox-os/wiki/Advanced-Arcade-on-Recalbox-(EN) In 4.0.0, you can choose different emulator for each game select your game button select metadata try emulator : libretro core mame : imame4all or mame2003 (mame 078) choose one exemple libretro snes Visionner l'image clic save, and try again your game


  • CRT Maniac

    @Acris Bizarre, j'utilise la même rom et le même émulateur (Imame4all Libretro, même taille même version) et le jeu crash après les 2 screens infos (nag screen). Impossible d'ouvrir RetroArch, il est planté. Reboot via console obligatoire (ou un kill). Je cherche pourquoi... Sur Imame4all LibRetro Recalbox 3.0.0b17, il fonctionne sans probleme, je l'ai lancé plusieurs fois. J'ai testé le Rewind=0, idem. Splatter House doesn't work on Recalbox 4.0, i don't know why, i'm looking for... ... Il fonctionne sur Recalbox 4 mais j'ai shunté configgen et j'ai passé mon fichier config a retroarch. Reste a comparer les différences entre mon fichier mame037.cfg et retroarchcustom.cfg Je poste mon fichier pour comparer. http://pastebin.com/9q5SGHyA Doit pas ya avoir quand chose qui bloque mais faut trouver... Si ça fait planter Splatter House, ça peut aussi faire planter d'autre jeux Splatterhouse runs on Recalbox 4 but with many changes .. for now ... No worries, it will work soon ...



  • Salut, Je vois que ça parle Français par ici ;-) Merci pour vos réponses en tout cas ! Je viens de tester la méthode d'Acris et même résultat que toi ironic (ce que j'avais déjà avant en modifiant le fichier de config). Si cela fonctionne bien en version 3.0.0, j'essayerai de tester quand j'aurais un peu de temps, à moins qu'un correctif ne passe avant sur la version 4.0.0 ... Encore merci pour votre aide ! Jérôme


  • Moderator
    Team

    Bonjour @ironic et @jeff j'ai testé aussi sur mon version recalbo 4.0.0 et effectivement j'ai pareil que toi ironic. Sous mame2003, nagscreen gauche droit et retour sur emulationstation sous imame4all, 2 nagscreen et ecran noir. Quand tu forces via un fichier cfg sous recalbox 4 , le jeu se lance ?


  • CRT Maniac

    Sorry for french language on english forum but we looking for why splatter house doesn't work. We a re near the solution.   Oui, je confirme, le jeu fonctionne sur 3.0 et 4.0 mais après modification. Je penses que c'est un paramètre du fichier "retroarchcustom.cfg" qui est envoyé a RetroArch lors du lancement de la rom qui pose probleme. Au début je pensais que c’était peut être la version 1.3 de RetroArch (1.2.2 sous Recalbox 3) ou autre chose. Il n'en ai rien. Le jeu fonctionne sans probleme particulier. Un jeu bien gore comme celui la, faut pas passer a coté :) Jason, qu'a tu fais a Recalbox 4 ?? Je poste quand même mes modifications (c'est plutôt des amputations, désolé) pour celui qui voudrais essayer. Il faut bien-sur sauvegarder ses fichier avant. Je réinstalle Recalbox 4.0.0b2 et je cherche ou est le soucis.

    (Wiki) Apparemment, les développeurs se sont inspirés du film Vendredi 13. Le héros de Splatterhouse ressemble beaucoup à Jason Voorhees, le tueur psychopathe du film Vendredi 13. Une rumeur dit que Namco s'est fortement inspiré de ce personnage après n'avoir pas obtenu les droits d'exploitation du personnage de Jason.

    Je pensais que c’était une licence officielle...   EDIT: Apparemment, même probleme pour Track'n Field (vu sur un autre post). Donc, il doit y avoir encore d'autres jeux... EDIT 2: La comparaison entre mon fichier qui fonctionne (même si c'est un fichier CFG de RetroArch 1.2.2) et le retroarchcustom.cfg de Recalbox 4.0.0b2 comparaison (mis a joute avec retroarchcustom.cfg pour iMAME4All). Il y a beaucoup de différences, comme les chemins et quelques autres paramètres mais ils sont sans importance. Y a une coquille quelque part... EDIT 3: - Installation toute fraiche de RecalBox 4.0.0b2 - Aucune modification dans les menus de EmulationStation a part activation du core LibRetro iMAME4All pour MAME. - Je lance Splatter House, au nag screen, j'ouvre RetroArch. - Quick menu / Close content - Je charge mon fichier config (modif du path avant dans setting/directory). - Je charge Splatter House (load content) -> ca crash !! ?? - Si je fais ca avec Track'n Field, ca crash a la page d'init du jeu. - je kill "Retroarch -l", le jeu se lance ??? mais probleme de screen, le moniteur swap entre l’écran de EmulationStation et le jeu (qui est jouable) toute les 8 secondes. Bref, ya un loup (frame buffer ??)...


  • Moderator
    Team

    J en ai parlé à la team Dev, il faut se pencher dessus. le lien pour comparer est mort


  • Moderator
    Team

    @ironic tu as testé la rom provenant du bon romset sous mame2003 ?


  • CRT Maniac

    Bon, j'ai refais la rom Splatter House pour mame 0.37 et mame 0.78 avec Rom Center (j'aime pas CLRmamePro). Elle sont effectivement différentes. Mais uniquement au niveua des noms des roms. - Recalbox 4 avec comme paramètres MAME: LibRetro et Mame 2003 et comme rom, la version 0.37 : * nag screen et retour a ES. * Lors du 2eme lancement, le jeu se lance : ok. - Recalbox 4 avec comme paramètres MAME: LibRetro et Mame2003 et comme rom, la version 0.78 : * nag screen, le jeu se lance au bout d'un moment mais est graphiquement corrompu. * Lors du 2eme lancement, retour a ES. Wouah c'est bizarre la, jamais le meme comportement, mon Recalbox 4.0.0b2 est tout neuf, aucune modif, même pas la langue. LibRetro MAME0.37 rom 0.37 : crash rom 0.78 : crash LibRetro MAME0.78 rom 0.37 : nag screen et retourn ES rom 0.78 : nag screen et retourn ES Bon, suis perplexe, des fois ça crash, des fois on voit le nag screen, des fois le jeu se lance mais en fausses couleurs et une fois j'ai reussi a lancer le jeu sans probleme. Tout ça en jouant simplement avec les 2 roms (0.37 et 0.78) et en changeant le core Libretro dans le menu d'ES. Ce qui est étrange également, c'est qu'avec mon fichier de config de retroarch 1.2.2, j'utilise le core libretro iMAME4ALL avec la rom 0.78 et ça fonctionne nickel. même avec Retroarch 1.3 sous Recalbox 4. J'en perds mon <del datetime="2016-03-31T20:13:42+00:00">lapin</del> latin. Diff-online a dégagé mes fichiers ??!! ... ya un ghost in the machine... <del>Comparaison</del>. www.diff-online.com c'est que très temporaire, même pas 24h, pfff !!!


  • Themer

    Il n'y aurait pas un fichier nvram de généré au premier lancement et qui serait nécessaire ?


  • CRT Maniac

    Non, pas de NVram ou autres... En lançant RetroArch du Shell (donc sans fichier de config) : Si je charge la Lib iMAME4All, il se lance avec la rom 0.37 et 0.78 mais a 0.01FPS, c'est hyper long, rien que pour voir s'afficher la page d'accueil. Par contre avec la Lib MAME2003 (rom 0.37 ou 0.78), j'ai une segmentation fault. En chargeant mon fichier de config de Recalbox 3, idem !! J'ai réussi a le lancer avec la Lib MAME2003 et la rom 0.78 (par contre, quelques bugs graphiques). ... Et la, je quitte, je relance la Lib MAME2003 avec la rom 0.78 et ... seg fault !! J'ai testé le retroarch 1.2.2 sur Recalbox 4.0.0b2 : IDEM !! J'ai testé la Lib MAME 2003 de Recalbox 3.3.0b17 (qui est la même que sur RB4 a l'octet pres) : IDEM ! J'ai donc : - Le même RetroArch que sur RBv3 - Les mêmes Libs que sur RBv3 - Les mêmes roms que sur RBv3 Résultats : IDEM ! (Bon, je sais, copier/coller l'exe de RetroArch dans RB4, c'est pas malin, c'est juste un essai). Je viens de refaire des testes sur RB3.3.0b17. RetroArch 1.2.2 avec la lib MAME0.37, accepte la rom 0.37 et la rom 0.78 sans probleme. RetroArch 1.2.2 avec la lib MAME0.78, retour a ES avec la rom 0.37 et la rom 0.78.


  • Moderator
    Team

    namco/taito games, on mame2003, should be fixed in the next beta release. I pushed a fix this morning.


  • Themer

    Is it a fix correcting a regression on 4.0.0 or a general fix correcting bug which was already present in 3.3.0 ? (in that case I'll have to retest some games)


Log in to reply
 

Want to support us ?

Join us on :

215
Online

28844
Users

14651
Topics

110724
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.