Odroid GO Advance Black Screen when starting SNES/PSP



  • Hi,
    been freshly imaging Recalbox 7.1.1. to an Odroid Go Advance.
    When starting an SNES or PSP rom, the screen will turn black an nothing happens. I am able to terminate the emulator and get back to the menu. NES seems to work.
    Been trying the images with Recalbox 7.1.1 for x64 also on an old laptop to make sure it is not the images causing the trouble --> everything working right away. So I assume it is some compatibility issue...
    Not finding anything in the changelogs - is that a known problem? Or anybody could give me more info how to debug?
    Thanks for your help in advance
    s_w


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @some_wizard Did you try with another SD card?
    Class 10 original SD cards are recommended.


  • Global moderator
    Global moderator
    Tester

    @some_wizard hello
    I just tried on my Odroid Go Advance using RCB v7.1.1, SNES system works fine. i don't try PSP, i don't install it yet, i'll have a look but snes works, the problem is somewhere else. Did you try with other roms ?



  • @Zing @Scavy Thank you for your reply.
    I am not sure what ultimately went wrong, but did re-image to another SD-card (...both Class 10...) and recopied the roms. For some strange reason it worked right away.

    So this is resolved. Thanks again!



Want to support us ?

207
Online

81.9k
Users

22.5k
Topics

162.8k
Posts