Raspberry Pi Imager Bricked My SD Card



  • Hi. I'm brand new here. I'm sorry I don't have any images as this all happened in real time and I thought I could salvage my 64GB SD card. So I had this card left over from an old Galaxy phone I had. It was formatted in ex-FAT. I know RB-Pi needs FAT file allocation, but I saw this Raspberry Pi imager program on Recalbox and thought all this would just work. Things were writing along and I stepped away. I came back to my computer and had an error message that something went wrong, and that I may have a bad drive. Prior to this there was nothing wrong with the SD Card. It was addressable by Win 10, had data on it, and I even made a backup of that data prior to doing all this. I deleted the data existing on the drive and ran the Imager then BRICK. So then I downloaded Etcher. And really had to be careful not to accidentally install a bunch of crapware btw. But while Etcher saw the drive it also ran into an error when I just tried to flash directly with the RB Pi 4 image. So I'm concerned about just buying another card and it being bricked also.

    Anyone have any thoughts or similar experiences? Thanks so much!



  • So I had another 8GB SD card I wanted to test. I just went straight to Etcher. This card already was formatted FAT32. Using the image file recalbox-rpi4.img.xz.Image of Etcher Brick.png


  • Staff
    Global moderator
    Team

    Hello
    replace your sdcard or adapter.
    It's not software problem, but hardware problem



  • @acris So I don't really know how you know that......

    But I did order a new 64GB SD Card from Amazon. I used the same adapter from my prior experience. I got it to work, but for others who were in my position and would like a step by step this is EXACTLY what I did:

    1. Insert the SD Card into the adapter and then the adapter into the computer. I made sure Win 10 could recognize it and verified that the format was ex-FAT.

    2. I then ran the SD Card Formatter application from https://www.sdcard.org/downloads/formatter_4/index.html
      version 5.0.1.

    3. I then launched the 1.5 version of Raspberry Pi Imager and selected Erase (format card as FAT32).

    4. I then selected Emulation and game OS and navigated to Recalbox 7.1.1. This time it worked!

    So even if you have a SDXC card that is functional, things seem very "tweaky" when you try to set them up for formats they were not designed to support (obviously).

    Hope this helps others!



Want to support us ?

328
Online

82.0k
Users

22.5k
Topics

163.0k
Posts