General performance problems on 90% of games



  • Morning gang and Happy New Year! I just got a Pi4 and used the Raspberry Pi Imager to install Recalbox on it. I've got Recalbox working on my TV the problem is it's running really chippy. The framerate on the Recalbox program itself is a little slow but digestible. The problem is that when I start up games they seem like they're having trouble working. Like the music skips as well as the graphics. I could take a little video if anyone is interested but any ideas about what might relieve this? I'm running SNES, GBA, Dreamcast, PSX, N64 and Genesis emulators. The only game that runs smoothly is Super Mario 64 lol. I tried running Ogre Battle 64 which ran smooth but had some music skipping.

    I tried changing emulators in metadata but that didn't work. I tried formatting the card and starting the process over, that didn't work. I HIGHLY doubt it's an overheating problem, someone already suggested that but I don't see how it could be since it's a problem right from startup.

    Anyway, let me know if you have any ideas! Thank you!



  • Stupid question, but, you HAVE disabled the "rewind" function?

    God knows why this is enabled by default.
    I keep forgetting myself with each build I do!



  • Hello! So I gave that a shot but it turns out it was not the problem.

    I think I may have figured out the problem though! For some reason Recalbox booted up in SD format and I noticed that it was running at 60 FPS compared to before when it was running at 10 FPS. When I restarted I noticed the HD was back to running at 10 FPS. So I connected my RP4 to a smaller TV and VOILA, everything is running smooth as hell! So it seems the problem is that my TV is asking for a bigger resolution than Recalbox can handle (at least I think). Does anyone know how to fix that so I can play on my bigger TV? I don't mind having to play at a lesser resolution.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @Chiva_Von_Chiva You can change the video mode:
    https://recalbox.gitbook.io/documentation/tutorials/video/display-configuration/complete-guide-on-video-configuration
    BUT, I believe your TV is 4k, and there is a known bug with 4k TVs and Rpi4:
    https://gitlab.com/recalbox/recalbox/-/issues/1384
    And this bug will be fixed in the next version:



Want to support us ?

334
Online

81.4k
Users

22.2k
Topics

161.3k
Posts