Impossible de désactiver les Shaders



  • Bonjour à tous,

    Ma config:
    RB 7.1.1 sur PI4 4Go oc@2GHz/750MHz
    Thème Next Pixel
    Shader appliqué depuis le menu principal (appliqué pour tous les émulateurs)

    Je continue ma découverte du monde formidable de Recalbox.
    Hier soir, j'ai voulu tester les shaders sur les jeux arcades.
    En voulant tester un shader en particulier, je l'ai activé, puis désactivé.
    Malheureusement, c'est impossible de désactiver le shader. 😥
    Si je chois un autre shader, ce nouveau shader est bien appliqué, mais lorsque je choisi "AUCUN", le shader reste bloqué sur le dernier choisi ?!? 😲🤯
    Le problème est apparu en faisant des tests sur FBneo et MAME.

    C'est comme si le choix "AUCUN" n'avait aucune action.
    Je n'ai pas eu le réflexe de vérifier ce qui se passe dans le fichier recalbox.conf. Je vais vérifier ce soir.

    Auriez-vous des suggestions ? Ou, mieux, est-ce que vous arrivez à reproduire ce problème ?


  • Staff
    Global moderator
    Team

    @LapinFou

    editer recalbox.conf.....



  • @acris OK Je vais regarder ça ce soir.
    As-tu pu reproduire le problème ?
    Je ne sais pas (encore) si c'est un bug RB ou un problème de thème.



  • Je viens de regarder le fichier recalbox.conf et j'ai ça:

    ## Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)
    global.shaders=
    

    Peut-être que cela devrait être comme cela ?

    ## Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)
    global.shaders=none
    

    Ou peut-être qu'il faut effacer la ligne ?
    Je voudrais être sûr de mon coup avant de tout péter. 😁



  • Pour être plus précis:

    ## Shader set 
    ## Automatically select shaders for all systems
    ## (none, retro, scanlines)
    global.shaderset=none
    
    ## Once enabled, your screen will be cropped, and you will have a pixel perfect image (0,1)
    global.integerscale=0
    
    ## Set gpslp shader for all emulators (prefer shadersets above). Absolute path (string)
    global.shaders=
    
    ## Set ratio for all emulators (auto,4/3,16/9,16/10,custom)
    global.ratio=auto
    


  • J'ai trouvé !!
    J'ai ajouté les overlay mises à disposition sur un autre topic de ce forum.
    Dans les fichiers [...]\overlays\mame\xxx.zip.cfg, il y a la ligne suivante:

    video_shader_enable = "true"
    

    Cela a pour conséquence de forcer le dernier shader choisi même si depuis l'interface ES le shader est désactivé.
    En commentant cette ligne, c'est bien ES qui reprend le contrôle des shaders.
    Je suis content, car cela me rendait fou cette histoire. 🤯



Want to support us ?

328
Online

81.4k
Users

22.2k
Topics

161.3k
Posts