No sound via HDMI on 4.0 Beta 1



  • Could anyone help me with my problem, that I do not have any sound on V4.0 Beta 1, while sound is fine with V3.3.0? System Volume is always zero and if i raise the volume, it has no effect and is not saved. In recalbox.conf everything looks fine. Even several fresh installs (also including unstable build) did not help. I use a Raspberry Pi 2. So obviously hardware is fine, because everything works in V3.3.0. What is wrong? Obviously no one else had this problem?!



  • hi, i am also lost alone with this sound. i think i remember it was working in 3.x, now i made a new sd-card for my raspberry with 4.0beta it is not working anymore. and shows exactly the same behaviour as you described. hmmmm.....waiting for more beta?....



  • Did you try setting audio mode to HDMI instead of AUTO in the ES menu? I have one TV that won't work on AUTO and I must force audio over HDMI to get sound.     Eric



  • The same is here. Tried your workaround with the HDMI audio mode, but no change at all. Something wierd is that the system volume bar is set to 0%. When I change it to any other number and confirm, then it does not change when I enter the audio settings again. But in the Recalbox manager it was accepted... seems it was not actualized..  Besides, audio in Version 3 of Recalbox works great. I am using the latest beta version till now. Hope this will be fixed soon. Cant play Tetris without sound!! ;)



  • Same problem. Ever find a solution?



  • Just wanted to add that sound works fine in kodi, just not in retropie.



  • I got the same problem
    Has anyone resolved this problem? 😕
    I'm using 4.0 beta 5



  • @Pedro-Garcia please start your own topic



  • I realize this post is old but I ran in to this same issue on a much newer verison of recalbox and this thread was first when searching "how to get sound to work on recalbox". I thought I'd post what I did to fix my issue to help other fellows.

    I have speakers in my monitor that Raspberry Pi only recognizes when the connected monitor is turned on BEFORE the Pi is turned on. Once this is done, go to main menu > sound settings, and make sure your settings are to your preferences. Note: I don't use auto for the output device (the auto setting has created problems for other users in the past).
    So if hardware is not working at all with your Raspberry Pi, trying connecting it to the Pi, turn on said hardward, then turn on your Pi.


Log in to reply
 

Want to support us ?

Join us on :

241
Online

28890
Users

14660
Topics

110801
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.