Manette 8bitdo M30 - A reconnecter à chaque lancement de rom



  • Bonjour à tous,

    Je remonte un bug que je rencontre pour la première fois. J'ai une manette M30 qui se connecte en bluetooth sans problème au lancement du système recalbox. Je peux naviguer dans les menus sans problème.
    Je suis sous 7.1.1 (je ne sais pas si le problème vient depuis la 7.0 mais je ne pense pas).

    A chaque fois que je lance un jeu, la manette n'est plus reconnu. Il faut que je redémarre la manette pour qu'elle soit reconnu dans le jeu.

    J'ai testé avec une autre manette (SN30) et pas de problème. J'ai fait un upgrade du firmware et pareil.

    Je précise que le problème ne se produit pas lorsque la manette est branchée en usb.

    J'ai réappairé la manette mais rien à faire.

    Une idée ?

    Merci d'avance.


  • Staff
    Global moderator
    Team

    @ramaduc

    la procédure est la suivante

    • oublier les manettes
    • redémarrer recalbox
    • refaire l appareillage en mode android ou switch si disponible.
    • appareillage ok
    • reconfigurer la manette dans le menu emulationstation > options manettes
    • retester.

    si ça ne fonctionne pas,
    refaire les mêmes étapes mais avant modifier la ligne ERTM dans recalbox.conf
    voir le sujet suivant : https://forum.recalbox.com/topic/8921/a-lire-manettes-8bitdo
    enregistrer les modifications
    rebooter.

    Si ça ne fonctionne toujours,
    refaire la manipulation inverse pour ERTM, et modifier la ligne
    global.input=auto en global.input=sdl2
    enregistrer
    rebooter.
    refaire l appareillage



  • @acris said in Manette 8bitdo M30 - A reconnecter à chaque lancement de rom:

    global.input

    Merci pour ta réponse.

    J'ai suivi chaque étape et malheureusement ça na pas fonctionné. Le paramètre sdl2 était pire car la manette n'était plus reconnu du tout (en appuyant sur les 4 boutons Y Z B C, je suis entré dans le menu retroarch mais je ne pouvais pas y faire grand chose).

    J'ai une autre recalbox en 7.0.1. Je testerai demain pour voir si ça vient bien de la dernière mise à jour.

    Merci pour ton aide.



  • Je précise que je suis sous Nespi4 Case et que j'ai interverti les 2 cables usb car ça posait des problèmes de lenteurs d'accès au SSD.



  • @acris said in Manette 8bitdo M30 - A reconnecter à chaque lancement de rom:

    @ramaduc

    la procédure est la suivante

    • oublier les manettes
    • redémarrer recalbox
    • refaire l appareillage en mode android ou switch si disponible.
    • appareillage ok
    • reconfigurer la manette dans le menu emulationstation > options manettes
    • retester.

    si ça ne fonctionne pas,
    refaire les mêmes étapes mais avant modifier la ligne ERTM dans recalbox.conf
    voir le sujet suivant : https://forum.recalbox.com/topic/8921/a-lire-manettes-8bitdo
    enregistrer les modifications
    rebooter.

    Si ça ne fonctionne toujours,
    refaire la manipulation inverse pour ERTM, et modifier la ligne
    global.input=auto en global.input=sdl2
    enregistrer
    rebooter.
    refaire l appareillage

    Après une fresh install 7.1.1 sur RPib3+, je viens d'exécuter la procédure que tu indiques pour une manette 8Bitdo M30 à jour (firmware M30_Firmware_V1.14):

    • controllers.bluetooth.ertm=1 (qui est la valeur par défaut dans recalbox.conf) et global.inputdriver=auto
      => comportement identique à celui décrit par @ramaduc
    • controllers.bluetooth.ertm=0 et global.inputdriver=sdl2
      => manette reconnue et appairée mais les inputs n'ont pas d'effet en jeu

  • Tester

    quelle board?


  • Staff
    Global moderator
    Team

    @ramaduc @BinaryNumber

    en ssh pouvez vous exécuter la manette usb & bt voir si tous les boutons réagissent : sdl2-jstest --test 0

    et avoir vous essayer le mode switch : start+Y ?


  • Tester

    Je confirme le mode Switch START+Y au démarrage résoud le problème. Manette reconnu sous le nom "Pro Controller" même si je suis moins fan que le nom réel de la manette



  • @Chriskt78 said in Manette 8bitdo M30 - A reconnecter à chaque lancement de rom:

    Je confirme le mode Switch START+Y au démarrage résoud le problème. Manette reconnu sous le nom "Pro Controller" même si je suis moins fan que le nom réel de la manette

    Je confirme aussi 🙂



  • Bonjour à tous,

    En effet, l'appairage en mode switch (start + Y) fonctionne.

    Par contre, j'ai configuré les boutons une première fois, j'ai lancé un jeu, ok, je ressors, je reviens, ok. En allant sur un autre système, je lance le jeu et là les boutons directionnelles ne répondaient plus.

    Après avoir configuré une 2e fois les boutons, c'est ok.

    A voir sur du plus long terme.

    Solution de contournement même si être reconnu en tant que manette Nintendo, pour une manette "Sega", ça fait drôle 🙂

    Merci pour l'info...en espérant que cela puisse être patché.


  • Global moderator
    Global moderator
    Tester

    @ramaduc
    Nintendo a toujours été plus fort que Sega,
    tout comme l'Amiga a toujours surpassé l'Atari ST...
    Ca m'étonne pas ^^



  • merci pour l'astuce 👍 ma manette fonctionne enfin même après redémarrage,
    sur recalbox 7.1.1 c'était ma seul manette a se montrer récalcitrante. mes autres pads étaient déjà au couleur de Nintendo. c'est ce qui devais lui manquer

    @Scavy

    text alternatif


  • Global moderator
    Global moderator
    Tester



  • Bonsoir,

    Je me permets de relancer le sujet car bien que le problème soit contourné lorsqu'une manette M30 est utilisée, ce n'est pas le cas lorsque 2 manettes le sont.

    La première manette paramétrée en pro controller, tout est ok. Lorsque je configure la 2e manette en tant que pro controller (ou même en tant que M30), les boutons directionnelles ne répondent plus. Il faut alors les mapper mais après avoir lancé un jeu alors c'est la 2e manette qui ne réponds plus comme il faut.

    Pouvez-vous remonter le problème aux devs s'il vous plaît ? Car il n'y avait jamais eu ce bug avant la 7.0

    @Scavy Je ne vais pas rentrer dans la polémique (même si Sega a toujours été plus fort 🙂

    Merci pour votre aide.


  • Staff
    Global moderator
    Team

    @ramaduc
    désactive le wifi et recommence
    vérifie que ERTM=1 dans recalbox.conf
    https://forum.recalbox.com/topic/8921/a-lire-manettes-8bitdo/2


  • Tester

    @ramaduc j'en ai qu'une, je peux pas aider plus ^^



  • This post is deleted!


  • This post is deleted!


  • @acris said in Manette 8bitdo M30 - A reconnecter à chaque lancement de rom:

    ERTM

    Bonjour,

    Je n'utilise pas le wifi et le paramètre ERTM est déjà =1.

    Je précise que j'ai un recalbox NESPI4 et qu'il n'y a plus ce problème. J'ai ce problème sur une autre recalbox "classique" (avec DD externe).

    J'essayerai de faire des tests et reviendrai vers vous.

    Merci


  • Staff
    Global moderator
    Team

    mode switch



Want to support us ?

273
Online

81.3k
Users

22.2k
Topics

161.1k
Posts