7.0.1 and RPi4 with Tankstick2 w/tri-mode



  • In the configuration settings, my X-Arcade Tankstick 2 w/tri-mode is detected and all buttons are mapped properly. However, when I launch any emulator... neither side of the (2player) controls work nor are detected in any way. I have to use my usb keyboard to exit.

    Thoughts? I haven't found anything specific from X-Arcade nor here so far... I'm feeling it could be an order of control selection issue, but P1 and P2 are set to the two sides of the tankstick2. I don't know how to find the right config to ensure the emulator chooses the correct interface.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • @Zing This is already set. I found that the tri-mode selector in mode 3 "sees" the tankstick properly, but when launching any of the emulators/games no controls are seen. I have to use a keyboard to exit.

    When I select mode 4, it detects 2x game pads but the tankstick2 controls work. However, the trackball still does nothing for any of the trackball games.

    So, I can play most of the systems now... but the config is a little backwards. And the trackball isn't recognized anywhere so far.



  • @gdenton Which plugs do you have plugged in to the pi?



  • @sroach I have both the serial/pc/mac USB and the trackball USB attached. I understood it to need both to see the the trackball as a mouse.



  • @gdenton,

    I know from what others say, mode 4 is not supposed to work, but it works the best for me. it shows up as two xbox controllers exactly what you are seeing and the button mapping follows the xbox controller mapping seen here:

    https://support.xgaming.com/support/solutions/articles/5000554993-how-to-use-x-arcade-with-raspberry-pi

    As far as the trackball, I found this on the XArcade support site, try unplugging the trackball usb and plug it in while it's up and running

    PI 4: We've heard some bugs reported with various game controllers and PI 4. With X-Arcade or any game controller, unplug the game controller, or USB for X-Arcade after the PI is running, then plug back in and trackball/X-Arcade will work. This bug impacts a number of USB devices with PI 4. We have no other solutions for it until they fix.



  • @sroach Right. The latest xarcade tri-mode firmware swaps mode 3 and mode 4. So, perhaps xarcade2jstick hasn't updated to recognize the tri-mode changes. Mode 4 is now the "it just works" mode, but the trackball is a wildcard still. Tried the unplug/plug trick...no change. I'll continue exploring what possible xarcade or emulator specific settings may be necessary...

    Oddly, if I flash a PlayBox based retropie...mode 3 is also seen as the xarcade, but no emulators see it upon starting a game. In mode 4, "most" of the buttons are detected and function within the emulators, but not all. So, recalbox has clearly done something extra for xarcade sticks. Nice job!



  • @sroach Updated: (Will be testing tomorrow)

    For arcade games be sure to choose lr-MAME 2003 as your emulator for full trackball support. You can also add other MAME builds like Advance MAME and MAME 2003-Plus (from the RetropPie Setup>Manage packages menu), but you will have to configure the controls for them (some added info on these further below). (MAME4all is not recommended in general and it requires additional setup. See MAME4All Controls section here if you decide to use it anyhow for some reason, but also note that it does not have trackball support!)



  • @gdenton dumb question. But assuming you enabled xarcade in the recalbox.conf?



  • @sroach No worries. Yes. Like I said, the only part not working now is trackball detection and unlike playbox/retropie builds, I haven't been able to determine how to install packages that could help with this. The usual apt/yum/zypper/git methods aren't present and parts of the filesystem are RO, so I didn't remount and tinker.



Want to support us ?

326
Online

81.4k
Users

22.2k
Topics

161.3k
Posts