Generic PS3 Controller no longer work in Recalbox 7.0.1



  • Hi everyone,

    I recently upgraded my Recalbox 6.1 to 7.0.1. I have a generic PS3 controller and, although it never worked with bluetooth, It always worked perfectly using an usb cable and Recalbox recognized it as a PS3 Controller. I did a fresh install of Recalbox 7.0.1 and copied back my roms, but now, my controller is not recognized, even using usb cable. I looked at recalbox config file and the PS3 controller option is enabled. Also, I tried the three driver options (bluez, official and Shanwan), but none of them worked. Is there any additional config or file I must download to make this controller to work in 7.0.1? Thanks in advance for any help.



  • @HotaruSama OK, so I did some tests, and I can confirm, that the problem only happens with Raspberry Pi 4. I have a Raspberry Pi 3B, and I did also a fresh install of 7.0.1 on it, and my generic PS3 controller is immediately recognized and works like a charm. So it seems there's a missing driver or config in the Pi 4 version of Recalbox. Is there any workaround for it? I can't use my Pi3 for recalbox because I need it for a project, and because of that, I bought the Pi 4 for Recalbox. I hope anyone can help me.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @HotaruSama It is strange to work on RPI3 and not work on RPI4, have you tried to connect a USB keyboard to RPi4 and, through the Emulationstation Menu to remap the control?



  • @Zing Hi. I've connected a keyboard and the gamepad thorugh usb ports to the RPi4, and went to "Controller Settings" in the UI. There I chose the "Configure a Controller" option, but "no gamepad detected" message is shown. Is really weird because RPi3 detects it automatically and it works.



  • @Zing I did another test. I went to another PC, then I've downloaded Recalbox 7.0.1 for RPi4 again, and I've installed Etcher. Flashed the image again in another microSD I had in my stuff, and put it in the RPi4. It didn't work. I've tried the three drivers included: bluez, Official and Shanwan with no luck.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @HotaruSama Okay, really from what you are describing the problem seems to be the lack of drivers, but, it is really unlikely that any control driver has been removed from the RPi4 image.
    Let's try to rule out all other possibilities first:

    • Are you using the latest official version downloaded directly from the Recalbox website?
    • Did you test with a TOTALLY clean and unmodified installation, before copying your stuff? If not, can you test? We have to rule out the possibility of a configuration conflict, which can happen if you use a configuration file from an earlier version that is incompatible.


  • @Zing HI Zing. I did the following tests:

    On the RPi4:

    • Downloaded Recalbox 7.0.1 from the official site for RPi4

    • Flashed image to micro SD card.

    • I've put the micro SD card on the RPi4 without any change or addition (roms, etc.)

    • Turned on RPi4 and let it load.

    • I've connected the PS3 gamepad with an USB cable, but it wasn't recognized.

    • I've connected a generic cheap PC gamepad I got just to test, and It was recognized, so I went to gamepad settings to try to add PS3 gamepad manually with no luck. It only shows 1 gamepad detected. (The cheap one)

    On the RPi3:

    • Downloaded Recalbox 7.0.1 for RPi3 from official site and I did all the same steps (flashing, and inserting to the RPi3 without any change or addition)

    • I've connected the PS3 gamepad with the USB cable, and then, a notification in the top right corner appears telling me that the gamepad was autoconfigured successfully , and I used it without any issue. I've connected also the cheap PC gamepad, and it was recognized as well, so when I go to gamepad settings, it shows "2 gamepads detected".


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @HotaruSama can you connect with SSH and give us the result of this command :
    sdl2-jstest --list



Want to support us ?

214
Online

80.3k
Users

21.5k
Topics

157.2k
Posts