8Bitdo Sn30 Pro and 7.0.1 RPi3

  • Hello,
    Again at 7.0.1 RPi3 I'm having problems with pairing 8bitdo controllers.
    I still have a SD card with Dragonblase 6.1.0 installed with works really fine with 8bitdo controllers - pairing is easy and it stays paired even after reboots.

    But in 7.0.1 I have problems connecting to 8bitdo. The same behavior was present in 6.1.1 (that´s why I was stuck with 6.1.0).

    Any way to bypass this? What changed from 6.1.1 onwards that is causing this problem and was not addressed in 7.0.X?

    Any help is appreciated.

  • Staff
    Global moderator

    you need to use android mode or switch mode to pair.

  • Global moderator
    Global moderator

    @skankster and don't forget to update your pads' firmware 😉

  • I had two problems with my bluetooth controllers, maybe the information is helpful for you.

    The first problem was that I wasn't able to pair anything. This could be resolved by disabling bluetooth ertm mode. To do this, add


    to recalbox.conf and reboot.

    The second one was that one of my SF30 pro lost connection after some restarts in regular intervals, so I had to remove all controllers and repeat pairing all of them. This problem vanished when I removed and paired the controller from the command line. Also, a keyboard that would refuse to pair from the GUI could be made working by pairing via command line. I don't know the reason, but you might want to give it a try.

  • Global moderator
    Global moderator

    @mauline normally, the controllers.bluetooth.ertm=1 command is better for a BT connection.

  • @Scavy Yes, maybe. But for me it was not 😏

  • @mauline Thanks for your reply and willingness to help.
    I did try pairing in android and switch mode. I also changed the line you suggested. But to no avail, ES recognizes the controller on the list of bt devices (correctly, with the correct 8bitdo Sn30Pro and everything) but stays on "In progress..." for a long time and then "Unable to pair controller".

    I've tried other bluetooth dongles and also the internal bluetooth. Nothing.
    This happens since version 6.1.1. I repeat, version 6.10 works FINE (on the same system, same bt dongle, same board, same everything). Tried the "pair from command line" on 6.1.1 and didnt work, so it will probably not work now again.

    I'm stuck on version 6.1.0 only because of this controller problem and it's frustrating...

  • @Scavy Thanks for the tip 🙂 But they're already on the last update!

  • Global moderator
    Global moderator

    @skankster Is you Pi installed in a case ? Did you try to appair the pads on a "nude" pi (i mean can you try with the board extracted from the case if you use one) ?

  • @Scavy Yeah, it is inside of a plastic case. I'll try to pair them again "nude" (the Pi, not me) and see if it works, but I'm kinda skeptic since I've tried to pair the 8bitdos very close to the case before and also my other sdcard with 6.1.0 pairs them well even at distance.
    Thanks again for your reply, I'll keep you guys informed.

  • i have problem with sn30/sf30 pro too. Gamepads can't pair automatically after restart. I need to connect manualy via keyboard

    System 7.0.1

  • Hi guys! I have started to have problems pairing 8bitdo Sn30 plus since I updated to 7.0.1 (I have RP4 now). The particular thing is that one joypad is paired but the other is struggling to do it(they are 8bitdo sn30 pro, the only difference is the colour. I have updated the firmware to the last version for both). And for struggling I mean that the joypad is pairing but when I switch off the RP4 I need to pair it again the next time I’m playing.


  • I can confirm that the pairing is lost sometimes (7.0.1 on RPi4, 2 x SN30 Pro in dinput/Android mode), but for me it does not depend on the number of controllers that I use. That is, I can pair both controllers, restart Recalbox and they will still be paired.

    What I noticed is that I have to turn off the controller when restarting Recalbox. Otherwise it won't connect, even though I'm back in ES and the controller LEDs are blinking (indicating that it's still trying to connect). When turning off the controller and then turn it on again, it connects instantly. I think this is rather an issue with the controller.

Want to support us ?