How to setup 6-button controller?



  • I‘ve bought a number of SEGA-style 6-button controllers like the retro-bit Saturn bluetooth controller or the M30 by 8BitDo.

    Since both EmulationStation and RetroArch basically assume a SNES/PS-style 4-button layout, how is one to get those 6-button controllers to work properly with the available SEGA emulators?

    I‘ve already tried mapping the Z and C buttons to L1/R1 or L2/R2. But depending on which SEGA emulator I‘ve tried, I never got the buttons to work as intended.


  • Staff
    Global moderator
    Team

    Hello you need to map L1 R1 on 5th and 6th button and/or L2 R2 on trigger buttton

    7f42ac24-42c0-11e6-8978-5f3cce723393.png

    7f43ae62-42c0-11e6-924a-50ca4e44f401.png



  • Thanks for the helpful diagrams.

    However, how come that the button layout for the Saturn and Mega Drive / Genesis controller differs for the X, Y and Z buttons? I would have expected them both to share the same button mapping so that the work the same for all Genesis and Saturn emulators.



  • I have a retro-bit Sega bluetooth controller and it took me a while to figure out how to pair and configure it correctly. I'm still having an issue with handoff from Emulation Station to Retroarch but it's playable.

    Anyway, I pair the controller using home+X. Then configure the buttons as follows in emulationstation:

    Controller == Emulation station
    B = A
    A = B
    Y = X
    X = Y
    Z = LB (ensure this configures as Axis 2+ not 2-)
    C = RB (ensure this configures as Axis5+ not 5-)
    LB = L2
    RB = R2
    Start = Start
    Select = Select
    Home = hotkey

    This configuration in emulationstation matches the normal buttons for StreetFighter2 on sega without any customizing the controller config in the emulator. To ensure Z and C configure as Axis 2+ and 5+ i have to hold them longer than usual or they detect as 2- and 5-. Sometimes have to redo C and Z multiple times to get it to detect as +.

    edit: this button config works but the problem I have is that after emulationstation goes black to enter the emulator, nothing happens until I turn off the controller (by holding the home button) and then turning it back on (by holding the home button). Then the game will play fine.


Log in to reply
 

Want to support us ?

404
Online

80.4k
Users

21.6k
Topics

157.8k
Posts