Change order of system 'Ports' not working (rest is working ok)



  • I've changed the order of systems in es_systems.cfg located at share/system/.emulationstation and all systems are ordered like I wanted however the order of 'Ports' does not seem to change at all.
    No matter what I do, it always shows up between Sega Megadrive and Sega 32X even though nothing can be found in es_systems.cfg between these systems.

    I can't see any fullname or platform called ports in es_systems.cfg either, all ports are still listed individually.
    Is there a way to sort the 'ports' system ? What fullname and platform should I add ?

    <?xml version="1.0"?>
    <systemList>
    <system>
    <fullname>Favorites</fullname>
    </system>
    <system>
    <fullname>Sega Master System / Mark III</fullname>
    <platform>mastersystem</platform>
    </system>
    <system>
    <fullname>Sega Megadrive</fullname>
    <platform>megadrive</platform>
    </system>
    <system>
    <fullname>Sega 32X</fullname>
    <platform>sega32x</platform>
    </system>


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @hitmaker As far as I know, it is not really possible to change the order of the PORTS in es_systems.cfg
    If I'm not mistaken, what you can do is, within the recalbox.conf file, overload the configuration with:
    emulationstation.ports.position=<index of position>
    A positive value is the index from the start, a negative index is the index from the end (-1 is the last position).
    It works with all virtual systems:
    emulationstation.<shortname>.position=index



  • @Zing Thanks for your help, am I supposed to edit recalbox.conf in share/system ? Let's say I want the 'ports' to be listed on the 10th place, where exactly do I need to add a new line or do I need to edit an existing one ?


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @hitmaker

    am I supposed to edit recalbox.conf in share/system ?

    Yes.

    Let's say I want the 'ports' to be listed on the 10th place, where exactly do I need to add a new line or do I need to edit an existing one ?

    You will need to add this line, it does not exist.

    Open recalbox.conf and search for "Arcade metasystem", you will see that this option is commented out:
    ; emulationstation.arcade.position = 0

    I would add just below that line, or, at the end of the existing lines in "Virtual systems" (which is just below "Arcade metasystem").

    If I'm not mistaken, there is no option to define the exact position, you can define it at the beginning or at the end, but, I never tested it, as I don't have this need.
    Test it, see what you get, and share it here.



  • @Zing many thanks, working ok now



  • Thank you very much, this solved my problem! I was changing things hundreds of times with no avail, luckily some laser-precise google search managed to find this blesses thread 😛



Want to support us ?

413
Online

80.4k
Users

21.6k
Topics

157.8k
Posts