Fresh install and not able to get hotkey to work on BT controller



  • i have a pi3 i just did a fresh install/load of recalbox using 7.0.1 .. i haven't messed with my console games in a while with recalbox... i'm using a BT Gamesir G3s.. i got it detected in ES and mapped

    A=1
    B=0
    X=4
    Y=3
    start=11
    select=10
    L1=6
    L2=7
    L3=13
    R3=14
    hotkey=10 select

    yet when i try and start any emulator it's like my hotkey is not working 😞 and even the keyboard escape key ?? what gives , any help or suggestions welcomed. and if you need any config file outputs i can get them for you.. here is my retroarch config

    ai_service_enable = false
    ai_service_mode = 0
    ai_service_source_lang = 0
    ai_service_target_lang = 0
    ai_service_url = http://localhost:4404/
    cache_directory = /recalbox/share/extractions/
    cheat_database_path = /recalbox/share_init/cheats/
    cheat_settings_path = /recalbox/share/cheats/saves/
    cheevos_badges_enable = true
    cheevos_enable = false
    cheevos_hardcore_mode_enable = false
    config_save_on_exit = false
    core_options_path = /recalbox/share/system/configs/retroarch/cores/retroarch-core-options.cfg
    fastforward_ratio = -1.0
    fps_show = false
    fps_update_interval = 256
    framecount_show = false
    global_core_options = true
    input_ai_service_axis = +1
    input_autodetect_enable = false
    input_cheat_index_minus_axis = -2
    input_cheat_index_plus_axis = +2
    input_cheat_toggle_axis = -3
    input_disk_eject_toggle_axis = -1
    input_disk_next_axis = +0
    input_disk_prev_axis = -0
    input_enable_hotkey = "escape"
    input_enable_hotkey_btn = 10
    input_exit_emulator_btn = 11
    input_fps_toggle_axis = +3
    input_hold_fast_forward_btn = h0right
    input_joypad_driver = udev
    input_libretro_device_p0 = 1
    input_libretro_device_p1 = 1
    input_libretro_device_p10 = 1
    input_libretro_device_p2 = 1
    input_libretro_device_p3 = 1
    input_libretro_device_p4 = 1
    input_libretro_device_p5 = 1
    input_libretro_device_p6 = 1
    input_libretro_device_p7 = 1
    input_libretro_device_p8 = 1
    input_libretro_device_p9 = 1
    input_load_state_btn = 3
    input_menu_toggle_btn = 1
    input_overlay_hide_in_menu = true
    input_player1_a_btn = 0
    input_player1_analog_dpad_mode = 1
    input_player1_b_btn = 1
    input_player1_down_btn = h0down
    input_player1_joypad_index = 0
    input_player1_l2_axis = -5
    input_player1_l3_btn = 13
    input_player1_l_btn = 6
    input_player1_l_x_minus_axis = -0
    input_player1_l_x_plus_axis = +0
    input_player1_l_y_minus_axis = -1
    input_player1_l_y_plus_axis = +1
    input_player1_left_btn = h0left
    input_player1_r2_axis = -4
    input_player1_r3_btn = 14
    input_player1_r_btn = 7
    input_player1_r_x_minus_axis = -2
    input_player1_r_x_plus_axis = +2
    input_player1_r_y_minus_axis = -3
    input_player1_r_y_plus_axis = +3
    input_player1_right_btn = h0right
    input_player1_select_btn = 10
    input_player1_start_btn = 11
    input_player1_up_btn = h0up
    input_player1_x_btn = 3
    input_player1_y_btn = 4
    input_recording_toggle_btn = 14
    input_reset_btn = 0
    input_rewind_btn = h0left
    input_save_state_btn = 4
    input_screenshot_btn = 6
    input_shader_next_axis = -4
    input_shader_prev_axis = -5
    input_state_slot_decrease_btn = h0down
    input_state_slot_increase_btn = h0up
    joypad_autoconfig_dir = /recalbox/share/system/configs/retroarch/inputs/
    libretro_log_level = 0
    log_verbosity = false
    menu_driver = ozone
    menu_show_restart_retroarch = false
    menu_swap_ok_cancel_buttons = true
    network_cmd_enable = true
    quit_press_twice = false
    recording_config_directory = /recalbox/share/screenshots/
    recording_output_directory = /recalbox/share/screenshots/
    rewind_buffer_size = 10
    rewind_enable = true
    rewind_granularity = 2
    rgui_extended_ascii = true
    rgui_show_start_screen = false
    save_file_compression = true
    savefile_directory = /recalbox/share/saves/atari2600
    savestate_auto_load = false
    savestate_auto_save = false
    savestate_directory = /recalbox/share/saves/atari2600
    savestate_file_compression = true
    screenshot_directory = /recalbox/share/screenshots/
    system_directory = /recalbox/share/bios/
    video_aspect_ratio_auto = true
    video_font_path = /usr/share/fonts/truetype/ubuntu_condensed.ttf
    video_fullscreen = true
    video_gpu_screenshot = true
    video_scale_integer = false
    video_shader_dir = /recalbox/share/shaders/
    video_shader_enable = false
    video_smooth = true
    video_threaded = false



  • actually it's not working in retroarch or the emulators like nes and mame. i just copied over 1 rom for nes and 1 for mame to test.. and the controller works fine in ES but once i start a game nothing is working ? 😞 i can't even escape key on keyboard i have to pull the power plug and power back on to get back into ES . i must be missing something here but can't seem to fig it out.. also i have Input P1 set to "#0 GAMESIR-G3S" in controller settings.. i also tried making L1 key my hotkey instead of select. still not working i can't even bring up retroarch using hotkey-B , again the hotkey is not working.



  • so still not working, So i reimaged again, this time i was able to take a 8bitdo snes 30 controller from my pi4 and BT link it to the pi 3 recalbox, and it works fine. i'm able to use hotkey ! So then i added my gamesir 3Gs mapped all it's keys same as before. reboot the pi3 , only turned on the Gamesir 3Gs and was able to start a game but the hotkey would not work ! i couldn't exit game nothing.. so i rebooted the pi 3, again using only gamesir controller and this time before starting a game went into controller settings and specifically set input P1 to "#0 GAMESIR-G3S" and started a game still unable to exit with hotkey and start.. again my hotkey is select key!! this is so frustrating. i only want to have the Gamesir 3Gs linked and working with the pi3


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator



  • OK so here is the lowdown :), i really think this is a Recalbox issue with 7.x, technically maybe Retroarch or ES or both i don't know, but at the end of the day a Recalbox issue :). I was able to recover a Recalbox 18.07.13 .img file from my online backup company πŸ˜‰ , i had not used my Recalbox pi 3 in a while, so i had upgraded to 7.x.. so WITH my same pi 3 and the 18.07.13 Recalbox, BOTH my GameSir 3Gs via BT work fine!! So It's NOT the BT controllers ..

    now on to what i found the issue to be.. So if i take the latest 7.0.1 Recalbox pi 3 image and load it fresh on my sd card, then try and add 1 of the GameSir 3Gs via BT they add fine and work fine in ES. THEN if I start a game say, one of the Atari 7800 games that comes with Recalbox, doesn't really matter what system, and Retroarch starts I am NOT able to use my GameSir BT 😞 . BUT HOLD ON.. if i turn off the power on the GameSir then power it back on magically it now works in said emulator and i can hotkey to my hearts content, BUT another issue, soon as I hotkey-B to get into Retroarch setup guess what ? the BT controller stops working again!! i have to power it off and on to get it to work in Retroarch setup. Then if i exit Retroarch setup guess what I have to power it off and on again πŸ™‚ to get it to work again in the emulator/game.. soon as I hotkey-start to exit the game and get back into ES, it works perfectly fine in ES no need to power off/on.

    YET i can reimage my sd card back to my old Recalbox 18.07.13 image and bam it's working perfectly! i never have to power on/off the BT controllers like i mentioned above in 7.0.1.

    Also i have some new Gamesir T4-pro, same thing happens on them i have to power off/on in 7.0.1 to get to work. What gives ?? πŸ™‚ i just want to understand is there some setting somewhere i don't know about ? is this a bug. i mean if you think about it logically there is no way it's the pi3 OR the BT controllers 😐

    here is a link to config files from both instances if i missed any let me know and i can provide, should i open this a bug on Recalbox Github ?

    https://drive.google.com/drive/folders/1l9jG4hSc2fdgiYuz3mkUEexynih7c-xn?usp=sharing



  • i just took time to test Retropie on the same Pi 3. worked fine/perfect, i was able to setup both GameSir BT controllers, but i really don't like Retropie :(, i prefer Recalbox. i'm pretty techincal but i'm throwing my arms up in frustration at this point, nothing is making sense.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @thanosazlin I was going to suggest that you open an issue on gitlab, but I saw that you already did that:
    https://gitlab.com/recalbox/recalbox/-/issues/1378
    Unfortunately, now it is necessary to wait...



  • so i'm really bummed 😞 , i hadn't used my pi and console games in over a year.. i'm sening my pi 3 to my best bud, i was going to load latest Recalbox on it , but had all these issues, so i'm sending it to him with 18.07.13 and the 2 GameSir BT controllers as a birthday gift. I had bought myself a new Pi 4 with 2 newer model GameSirs and damn it πŸ™‚ i just can't get it to work with Recalbox 7.x , least with these GameSirs.. so i'm going to just have to load Retropie on it until someone picks up this issue on Gitlab.. but i won't be able to do any repro for them if they as because the pi 3 is leaving me tomorrow. It's weird that the Pi 4 !!! even has the same issues. Unfortunately i don't have a 18.07.13 image for the Pi 4 since i only have had it for a week, and don't know if 18.07.13 would even work on a Pi 4. man i hope they help me resolve this soon.


  • Global moderator Translator
    Translation Master
    Tester
    Global moderator

    @thanosazlin

    don't know if 18.07.13 would even work on a Pi 4.

    Recalbox has only become compatible with Rpi4 since version 7.0.



  • @thanosazlin said in Fresh install and not able to get hotkey to work on BT controller:

    so still not working, So i reimaged again, this time i was able to take a 8bitdo snes 30 controller from my pi4 and BT link it to the pi 3 recalbox, and it works fine. i'm able to use hotkey !
    That's weird because I'm having the same issue but with the 8bitdo NES30 pro controllers, too bad I don't have a GAMESIR to see if it works for me, maybe then we can just exchange our SD cars! 😁



Want to support us ?

256
Online

80.5k
Users

21.6k
Topics

158.2k
Posts