Updating to 4.0 Beta?



  • Just wondering, I am on 3.3.0-beta17 and I have tried going to system update and updating to get to 4.0 but it says no updates available? Am I going to have to completely start from scratch again?  Is there a manual way to update?



  • from scratch dude, yes. Too much improvements on 4.0.0 to allow upgrade from 3.3.0


  • Moderator
    Team

    You can save your essential data on you computer, make a fresh install and put inside your save... :s Sorry guy but they have a lot of news inside the 4.0 :s.



  • Yea understood was just hoping. Is there a more full change-release for updates like this?  For example I read the release notes, but I was looking for more documentation on the changes to gamelist.xml  where the .emulationstation folder is more specifics around the drivers that were updated etc.



  • not sure if there will be doc on that but i can tell you the basics user root's HOME moved from /root to /recalbox/share/system, where you will find again .emulationstation. General information concerning scraping and gamelist.xml : it's now in the roms system folder. We wanted to make a whole of the /recalbox/share as we can now setup some removable devices. We thought that the scraping dat was part of the /recalbox/share stuff, and not a RecalboxOS thing !do you have any spcific question concerning gamelist.xml ?



  • Well just because I have not tested, sseph scraper again, on last build it was correctly placing image data into downloaded_images and gamelist.xml into .emulationstatin/gamelist/systemdir/ Looks like fba_libretro was updated to the right folder name so that is awesome. I guess I will not have any until, i run sseph and see if there is any problems. Mainly just looking for more info a layer between dev and user, but suppose can just dive deeper into github/issues.   Which IRC was more active or it may be just because I am an english speaker :) Curious about how to send you guys device info of controllers to get support for.  For example I have a Mortal Kombat Xbone/360 pad that is detected and shows up in /dev/input  but will not register button clicks.  If I sent you guys the controller  or what information from /dev/input of /var/log/messages to submit to you to get it to work, or just open up a page in github?



  • thegameddb.net is out of service, don't try sselph's scraper. You may have noticed a pinned thread about scraping from recalbox : that's a script i wrote. There is a specific version for 4.0.0 (not yet mentinned in the topic) which has been wworking good so far. But it's based on sselph and tgdb.net, so you can't use it for now. Usually, the best way to get in touch with the devs is a goold old retro IRC. We all speak english ;) Concerning your pad, first you should try evtest. But you can also post on the troubleshooting section of the forum. Have you tried xboxdrv ?



  • Yea I disabled PS3 drivers, enabled Xboxdrv it was detected before and after but the same issue persists. I tried jstest and just have no inputs.  I plugged it into xbox360 to confirm its working.  ON a 360 the led lights go stable and stay on on the pi they just blink.   No errors in /var/log/messages would be helpfull if we had a troubleshooting standard to follow before posting on troubleshooting everything the devs would like us to check, look for what output they would need to start.


Log in to reply
 

Want to support us ?

Join us on :

344
Online

29926
Users

14913
Topics

112252
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.