Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

SMB not working in Recalbox v7.0



  • Many people are using a NAS nowadays. Probably the most commonly used protocol is Server Message Block (SMB). This could be utilized since the XBox Media Center days. SMB is still available when adding a new source, but it is not working in Recalbox v7.0. It had been working in v6.1.1 just fine.

    details:
    When creating a new source, I choose SMB, but none of the sources on the network show. There are usually at least two: my NAS and my router.
    When I create the source manually, I enter all details and when finished, Kodi instantly reports "software caused connection abort", therefore it seems that it is not even trying to connect. On the other hand, when my NAS is off, the error message reads something like "no route to server".

    side note:
    EmulationStation states in network settings that it is "not connected", even though wifi is connected and a LAN cable is plugged in. Yet Kodi tells that it is connected properly (in its network settings).
    Another hint in this direction: when I manually create an SMB share, Kodi states "the connection to the network location couldn't be established. This could be due to the network not being connected. Would you like to add it anyway?"

    The raspi is obviously connected to the network since it received its static DHCP IP address from the router and can play youtube videos. I can ping the raspi from my PC.

    Hardware: Raspi 3b+


  • Global moderator
    Team

    Hello
    wait recalbox 7.0.1 tonight 9.00 pm CET France.
    https://forum.recalbox.com/topic/21798/recalbox-7-0-1-on-rail

    Please update your recalbox and try again after.



  • Thanks for the heads-up.

    The problem still persists in v7.0.1
    I tried a fresh install, same problem.


  • Global moderator
    Tester

    @Tosnic
    Here below you will be able so source example working fine with 7.0
    link : https://recalbox.gitbook.io/tutorials/v/francais/reseau/partage/charger-ses-roms-depuis-un-partage-reseau-samba-un-nas-par-exemple

    Command line : sharenetwork_<nfs|smb><[0-9]>=<SHARE|ROMS|SAVES|BIOS|MUSIC|OVERLAYS|SCREENSHOTS|SHADERS|SCRIPTS>@<NAS>:<répertoire partagé>:<options>



  • sorry, I am not capable of French



  • @olivierdroid92 According to Google Translate, in this tutorial you would replace the SD card as the rom location. Plus, this tutorial seems to only affect EmulationStation. My problem is with Kodi.

    Can anyone confirm whether my issue is with Recalbox v7 or stemming from my setup?
    I found some strange things today, looking into my router's interface. There were 2 IP addresses associated with the Raspi system, but none of those MACs matched the MAC that Kodi presents. Kodi shows the same address as ifconfig via SSH.



  • After forcefully removing all static DHCP references from my router concerning my Raspi, it now is assigned random IP addresses (like in most setups). Now EmulationStation shows "connected" in its network settings.
    Still, the problem persists.

    I tried my previous installation of Recalbox v6.1.1 (thankfully, I used another SD card for v7). This installation still works fine regarding SMB.



  • @Tosnic

    If your nas support dlna try to activate unpp in settings menu in kodi ! I'm not sure but thinking it was active by default in previous releases now you have to activate unpp.



  • @dstroy It seems that way. In Kodi Krypton I could not find the option to toggle UPnP. In Kodi Leia the option is disabled by default.
    But changing to DLNA would simply circumvent the issue, not solve it.


Log in to reply
 

Want to support us ?

237
Online

79.6k
Users

21.0k
Topics

153.6k
Posts