problème configuration 8bit do NES30 pro.


  • Global moderator
    Tester

    @disizrom1 salut, tiens essaie voir ici, retente avec les conseils donnés et poste le résultat de la commande.



  • Merci, j'essaye de m'en occuper au plus tôt !


  • Screenscraper
    Developer
    Global moderator
    Team

    Dans quel mode se trouve le pad?



  • Bonjour,
    Je rencontre le même problème (manette NES30 PRO v1)/ Rpi3b+). Lors de l'affectation des touches L2 /R2 sont reconnus comme "axis".

    Voici les actions/tests effectués :

    1. vérification du firmware > déjà à jour

    2. par défaut manettes en mode Switch (d'après le manuel officiel : https://download.8bitdo.com/Manual/Controller/N30pro+F30pro/N30pro+F30pro_Manual_V4.pdf) j'ai pas encore essayé le mode android mais je vais le faire dès que possible (à savoir avant la vr 7 je n'ai jamais eu besoin de démarrer dans un mode différent de celui par défaut).

    3. suppression des manettes enregistrées + modification du fichier "es_input.cfg" pour remplacer les "axis" par "button" + désactivation du wifi + nouvelle association des manettes et affectations des touches + A/M > idem

    4. nouvelle modification du fichier "es_input.cfg" + A/M > idem

    5. même problème avec la MAJ 7.0.1 et ceux en suivant à nouveau l'étape "3."

    6. j'ai à nouveau appliqué l'étape "3." cette fois j'ai configuré les manettes sans Bluetooth et L2/R2 sont apparus dans le menu en button mais malheureusement le prb est resté le même.

    Retour de la commande "sdl2-jstest --list" :

    sdl2-jstest --list

    error: failed to read gamecontrollerdb.txt: Invalid RWops
    Found 1 joystick(s)

    Joystick Name: '8Bitdo NES30 Pro'
    Joystick Path: '/dev/input/event0'
    Joystick GUID: 05000000c82d00002038000000010000
    Joystick Number: 0
    Number of Axes: 6
    Number of Buttons: 16
    Number of Hats: 1
    Number of Balls: 0
    GameControllerConfig:
    Name: '8BitDo NES30 Pro'
    Mapping: '05000000c82d00002038000000010000,8BitDo NES30 Pro,a:b1,b:b0,back:b10 ,dpdown:h0.4,dpleft:h0.8,dpright:h0.2,dpup:h0.1,guide:b2,leftshoulder:b6,leftsti ck:b13,lefttrigger:a5,leftx:a0,lefty:a1,rightshoulder:b7,rightstick:b14,righttri gger:a4,rightx:a2,righty:a3,start:b11,x:b4,y:b3,'
    Axis code 0: 0
    Axis code 1: 1
    Axis code 2: 2
    Axis code 3: 5
    Axis code 4: 9
    Axis code 5: 10
    Button code 0: 304
    Button code 1: 305
    Button code 2: 306
    Button code 3: 307
    Button code 4: 308
    Button code 5: 309
    Button code 6: 310
    Button code 7: 311
    Button code 8: 312
    Button code 9: 313
    Button code 10: 314
    Button code 11: 315
    Button code 12: 316
    Button code 13: 317
    Button code 14: 318
    Button code 15: 319
    Hat code 0: 16



  • Avec le mode Android, ça reconnait aussi les touches en tant qu'axe.

    Je tenterais d'abord d'allumer la manette en mode Android histoire de savoir si ça ne règle pas déjà le problème 🙂



  • @tony-c Si j'ai bien compris le manuel, finalement par défaut la manette démarre en mode Android "appuyez et maintenez power pendant 1 seconde pour allumer, les voyants du contrôleur clignoteront une fois par cycle" ici pas de combinaison de touches.

    Donc je pensais être en mode switch mais j'étais en mode android.

    test en mode switch (power + Y) + nouvelle association = manette reconnu comme PRO Controller plus 8bitdo NES 30 PRO)
    config des touches, L2/R2 bien reconnus en button
    test en jeu = toujours KO


  • Global moderator
    Tester

    @tony-c hello @Bkg2k tu peux regarder le résultat de sa commande stp ? Merci 🙂



  • @tony-c Pour être sûr j'ai à nouveau supprimé toutes les manettes associées, mais cette fois j'ai connecté une autre manette en filaire pour faire la conf.

    • J'ai allumé une des manettes NES330 PRO en mode switch
    • Config des touchers OK
    • J'ai regardé dans le fichier "es_input.cfg" OK
    • Test en jeu OK !
    • Même manip pour la 2éme manette, cette fois j'ai du utiliser le bouton d'appairage de la manette, mais OK
    • Test en jeu OK également

    Le problème semble résolu !
    Par contre autre problème, dans Mario Kart 64 L1/R1 KO je cherche.


  • Global moderator
    Team

    @tony-c

    supprime le fichier suivant :

    /recalbox/share/system/configs/mupen64/input.xml
    reboot recalbox
    et reteste, si ça fonctionne toujours pas, retente un remap de la manette de nouveau et reteste.



  • @acris Super ! ça fonctionne, merci j'aurais surement passé un peu de temps à chercher sur le forum. Bonne soirée.


Log in to reply
 

Want to support us ?

168
Online

79.8k
Users

21.1k
Topics

154.8k
Posts