Screenscaper issue

For information, Screenscraper website is currently down. All the Screenscraper staff is aware of this issue. Until it's solved, you won't be able to scrap from Recalbox or Skraper. We apologize for the inconvenience.

Pour information, le site internet de Screenscraper est actuellement en panne. Toute l'équipe de Screenscraper est consciente de ce problème. Tant qu'il ne sera pas résolu, vous ne pourrez pas scraper depuis Recalbox ou Skraper. Veuillez nous excuser pour le dérangement.

The Recalbox Team.

[RECALBOX 7] missing libretro/pcsx_rearmed bios for PSX games



  • Hi all,

    I had this error message this morning when I tried my psx games, related to missing libretro/pcsx_rearmed bios.
    It also tells that there might be a problem with the md5 checksum and I confirm it is related.

    Here is what I did to solve it :

    • get all missing bios for psx : the list is available in the bios menu / section psx (you can use a pack like BIOS_Recalbox_4.1_18.02.09)
    • add the missing bios to the \RECALBOX\share\bios\ folder : SCPH1001.BIN, SCPH7001.BIN, scph5502.bin, SCPH1002.BIN, SCPH7002.BIN, SCPH101.BIN)
    • Install Putty tool
    • run this ms-dos commands, to make recalbox's config files writable :
      cd C:\Program Files\PuTTY
      plink RECALBOX -l root -pw recalboxroot mount -o remount, rw /
    • connect to your recalbox using ssh/putty :
      create a session with hostname "root@recalbox"
    • open the bios config file :
      nano /recalbox/share_init/system/.emulationstation/es_bios.xml
    • look for the system playstation :
      ctrl+w , type psx, enter
    • in the section psx, replace md5 value of bios "scph1001.bin", (dc2b9bf8da62ec93e868cfd29f0d067d) with this value : "924e392ed05558ffdb115408c263dccf"
      this is the correct md5 value for the bios file
    • save the file (ctrl+x, yes)
    • reboot recalbox
    • check that in the bios menu that psx bios are all valid
    • run your favorite game

    If some games still cannot be lauched, like me you can :

    • add bios "dtl-h1001.bin"
    • add the bios in the es_bios.xml file, in the "psx section", like this :
      <bios path="dtl-h1001.bin" md5="dc2b9bf8da62ec93e868cfd29f0d067d" core="pcsx_rearmed" note="Recommended for better compatibility." />

    Hope this helps!



  • Hi, I was dealing with this too today, but I didn't know where to store the correct MD5 hash. Thanks for that, works well now!

    Best Regards



Want to support us ?

384
Online

79.7k
Users

21.1k
Topics

154.4k
Posts