Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

KODI sur recalbox - Certaines videos sont lancées uniquement avec le son



  • Bonjour,

    j'ai un soucis avec certaines vidéos lancées via le KODI fourni avec Recalbox : quand je lance la vidéo, le menu de sélection de la vidéo reste ouvert, le fond devient noir et le son se lance.
    Je n'arrive pas à comprendre pourquoi.

    J'ai essayé plusieurs astuces sur internet :

    • vider le cache de KODI via Indigo
    • dans les paramètres du lecteur vidéo, désactiver les accélérations matérielles (OMXPlayer et MMAL)

    Mais ces solutions ne marchent pas.

    voici ma config :

    matériel :

    • CPU : ARMv7 Processor rev 4 (v7l)
    • BogoMips : 76.80
    • Hardware : BCM2835
    • Revision : 2a22082
    • Memoire totale : 558 MB

    OS : Kodi 17.6 Git:20191113-nogitfound

    Video :

    • Résolution : 1360x768@60.00Hz - Plein ecran
    • Vendeur OpenGL : Broadcom
    • Version openGL : OpenGL ES 2.0

    Mon KODI est connecté sur un NAS qui contient mes vidéos.

    Aucun problème habituellement sauf pour certaines vidéos.

    J'ai les logs du moment où je lance la video : https://pastebin.com/xMGxccUr

    je vois dans les erreurs plusieurs choses :

    ERROR: CMMALVideo::Open : Video codec unknown: ae
    
    ERROR: CMMALRenderer::Configure - format:2 not supported
    
    ERROR: OutputPicture - failed to configure renderer
    
    DEBUG: ActiveAE::SyncStream - average error of 2.426791, start adjusting
    DEBUG: ActiveAE::SyncStream - average error 0.426791 below threshold of 30.000000
    
    DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-30442.164076, adjusted:-30442.164076
    

    Je bloque, je n'arrive pas à trouver comment débloquer ça.

    Merci d'avance pour ceux qui m'aideront.


  • Global moderator
    Team

    Bonjour
    quel codec vidéo est utlisé par ta vidéo ? toutes les vidéos ?



  • Bonjour,

    Non pas toutes les vidéos, la plupart marche.
    pour l'instant, ça bloque sur une saison d'un animé et sur un film. Y'en a peut-être d'autres, que je n'ai pas détecté.

    Quand je lance la video sur VLC, sous windows, aucun soucis.

    VLC me donne les codecs suivants :

    • Codec : MPEG-H Part2/HEVC (H.265) (hevc)
    • Type : video
    • Résolution video: 1920x1088
    • Dimension du tampon : 1920x1088
    • Débit d'images : 23.976216
    • Format décodé : planar 4:2:0 YUV 10-bit LE
    • Orientation : Haut-gauche

    Merci à toi.



  • Les pi 3 ou moins sont trop justes pour lire du H265.
    Sur ces PI, le H265 doit être décodé logiciellement et le processeur n'est pas assez puissant...

    Zetof



Want to support us ?

135
Online

78.5k
Users

20.1k
Topics

147.6k
Posts