Problem with Recalbox6.1.1 with 64GB Sd Card and Raspberry pi3b+.

  • Hi, for the past two weeks I've been trying to install the Dragonblaze update on my new Raspberry pi3b+. Unfortunately I can't access Recalbox once the raspberry is powered on. I have the fixed red Pwr light that stays on and no Boot.I have been using Recalbox for several years now and have never had this problem before.

    I have always done the same procedure to install Recalbox:

    -> Format my 64GB Sd Card with guiformat
    -> Install the .img with Etcher portable version

    Nothing works, the Raspberry always stays in fixed red light mode... as if the Sd Card wasn't recognized...

    I've tried using other formatting software in Fat32.
    I checked with AOMEI Partition Assistant if there was not a partition problem after installation.
    I bought a new Sd card to see if mine had a problem.
    I tried different cables and USB charger to see if there was a voltage problem.
    Could it be the raspberry itself. Defect or something else? ( It has never had a problem before for the old ones )

    Can the Dragonblaze update cause problems with cards over 32GB or the raspberry Pi3b+ model?

    I don't know what to do, so if someone has had this kind of problem before or thinks they can find a solution.

    Thank you in advance

  • @sng You have already tested most of the possible solutions. I'll give you a stupid solution, but for some reason it may be the right one. Try using the normal version of Etcher. EDIT: Use a program like HDTune and scan the memory card, see if there are any "bad blocks".

  • Thank you for ansring me ismaiden666 .After checking if there was no error on the SD card and trying to install with the normal Etcher version. Nothing changes and it still doesn't work... So I'm going to stop trying with Recalbox and switch to Batocera ! Maybe I'll come back if an update and corrections are done on dragonblaze.

    See ya

Want to support us ?