PS3 Controller - free beer



  • Hi folks, first of all. sorry no free beer. but I can imagine that this topic is getting boring. I am reading now for 4 days straight to get the ultimate rasp pi  with retro gaming working. The PS3 Controller is now my Endboss. I´ve got: Noobs, recalbox, respbian and two PS3 wireless Dualshock 3 - SixAxis (CECHZC2E A1) The bluetooth dongle is: tinxi® Bluetooth 4.0 USB Adapter V4.0 On the dongle is written CSR 4.0. A similar one is listed in the Compatibility List as not working. BUT. When checked via hcitool scan the dongle can a least find the imac. But no Controller. I already ordered another one from the list and cross my fingers. Love what you do here and looking forward to any tips or recommendations.



  • I´ve bought another two bluetooh dongle: CSL - USB nano Bluetooth-Adapter V4.0 <span style="color: #0066c0; font-family: Arial, sans-serif; font-size: 13px; line-height: 19px;">Trust BT-2400p</span> and it is still noch working. I can even found them in Rasbian!? This is anoying as hell. Any help?



  • Hi, How do you try to connect your controller? There is an easy way, first you have to wire your controller with a USB / micro usb link. Then you wait 10s, and you disconnect it. After that, your controller should blink fast and it's ok!



  • I tried that and it does not work. It is blinking fast but after that there is no reaction to controller inputs. :(



  • Did you try to edit PS3 driver section in recalbox.conf? switch "official" to "shanwan".



  • Yes, got it. That was the problem. They worked for some time. But now just one of the controller is working and the other one is just trying to pair but without any luck. What can I do in raspbian to check where the problem is? hcitools dev? some test for the dongle?



  • Are they all same controller model ? Because there is too "gasia" PS3 copy. I cant help you with linux command, sorry x) Plus you can pair only two controller at same time.



  • They are both definitly shawan. Checken that via dmesg and usb connection. They worked before. When I try to pair (root > usb connect > dmesg > unplug > pair button on controller > dmesg) there is the following error message: can't add hid device -32 probe of 1-1.5:1.0 failed with error can't set operational mode   one ist still working and pairing works easy. a look in to etc/var?/bin/bluetooth reveals one folder with the adress: xx:xx:xx:xx:xx any ideas?


  • Moderator
    Team
    Moderator
    Translator

    Can you try something...? I have two shanwan controllers too and for some reason I can only pair the second one only after pairing the other one. It will just not pair as first controller.



  • I tried both way. No chance. I would like to delete the known devices and start the pairing fresh. maybe that works


Log in to reply
 

Want to support us ?

Join us on :

281
Online

28174
Users

14427
Topics

109179
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.