Recalbox 7.0

Black screen in n64 games in x86_64



  • Hi everyone. I have been searching in the forum and have read many threads but haven´t found the solution yet.
    When trying to run N64 games the screen goes black but I can hear the sound. Info:

    • Recalbox version: x86_64 bits 6.1.1-Dragonblaze
    • Emulator: MUPEN64PLUS
    • Core: GLIDE64MK2

    If I select the other available core I can see the image but it is too slow. I have also tested batocera with the same emulator+core just to double check if is something related to my PC but it worked correctly.

    Does anyone have the same issue? Thank you


  • Developer
    Team
    Global moderator
    Netplay

    hi @pmroyo
    please give me more information to pc Configuration .
    I think the problem comes from the framebuffer you have an nvidia video card or something else?



  • Hi @strodown and thank you for your response. I am using an old laptop: intel core 2 duo t5500, 1gb RAM and integrated graphics. I suppose it is not a hardware issue because N64 games run perfect using batocera.



  • Do someone have the same problem? I haven´t found the solution yet



  • I'm pretty new to this but I'm also having this issue. I don't have much details for my specs at the moment but im using a little SFF computer with an i5 cpu, no GPU and booting/running off a 32gb usb. I really haven't done much troubleshooting as I'm an amateur with this stuff but would love to find out if there is an easy fix. 🙂



  • @pmroyo I have the same problem and I have not found a solution. I hope someone shares the solution



  • Excuse me, but I have the same problem with n64.
    Platform : rpi3., 6.1.1 dragon blaze.
    Issue the same as in x86_64 platforms.
    As I try to launch any game it goes back to ES.
    Sometimes it gets black screen and nothing happens anymore.
    I read a couple instructions, tried to change video modes, tried to change a couple of configs in recalbox.conf and mupen65plus. Nothing helped.
    Controller : DS3 original. Any other platforms works fine. I'd like to mention the fact that the problem only when you use mupen64plus as a main emulator. Libretro plus mupen64 core works,but slow. It'd be nice if someone find a solution.



  • I have a similar/same issue (only now i seem to be making backward progress)

    Platform :

    • Old model Dell Optiplex 755 with an core 2 cpu, no GPU and booting/running off a 32gb usb

    • 6.1.1 dragon blaze. x86_64 (also had x86 running on it yesterday)

    • wired keyboard (but did not work with PowerA Mini xbox controler)

    with a fresh install i can hear the game and navigate it, but not see anything. While i suspect that it might be the lack of a dedicated graphics card on an old machine, i followed this https://github.com/recalbox/recalbox-os/wiki/N64-%3A-return-to-ES-(EN) i had found in the readme int he rom folder. I was able to follow everything in the instructions (not the first time by any means) but the TV (and monitor) i have these connected to do not offer a list of options, like the write up suggest. so i am stuck with a higher than desired resolution without being able to change it.

    Have tried the different cores as well.

    Since messing around with it i am now unable to even get it to run (with black screen) it just boots me out.

    Suggestions?



  • I feel like I changed the screen ratio and it helped before. I’m really new to this also and can’t confirm cause now my n64 games ain’t working either. 😔



  • Ok fixed it!!! Try...

    setting the resolution to 4:3 ratio with Libretro for n64 games.

    I have a optiplex 360 with a hdmi card adapter.



  • @dj_lithium said in Black screen in n64 games in x86_64:

    Ok fixed it!!! Try...

    setting the resolution to 4:3 ratio with Libretro for n64 games.

    I have a optiplex 360 with a hdmi card adapter.

    Glad you got it. I tried your suggestion, but did not make any difference for my set-up


Log in to reply
 

Want to support us ?

104
Online

79.1k
Users

20.4k
Topics

149.2k
Posts