No Wired Network on boot



  • When I connect the LAN cable to the Raspberry Pi 2 it does not obtain a DHCP address and I am unable to locate it on the LAN. The network settings screen reads as unconnected and when I try to scrape the games it says it's offline. Any suggestions?



  • The Pi is supposed to be connected to the lan before it boots



  • I have also tried this option and there is no IP address obtained. I have tried this on 5 seperate Raspberry Pi 2's with 5 seperate installs of Recalbox (I am building Recalbox Console Kits for people after they seen mine on Facebook) When I modify /etc/network/interfaces to put eth0 into static mode it works fine but DHCP is not working. I will configure port mirroring on my switch and capture a Wireshark trace to see what is going on.



  • maybe a silly question : your DHCP server work well ? if you try another device in DHCP, is it ok ? Haven't you blacklist or not anough IP range in your DHCP ? if it's work with static IP, no reason it doesn't work in dhcp...



  • I have a known good working DHCP server (CISCO 800 Series Router with latest IOS release) I have plenty of IP Addresses available in my scope and all other devices on my LAN obtain IPs correctly. There are no blacklists or other security preventing the Pi 2 from obtaining a lease. If I use a Raspbian formatted SD Card it obtains a DHCP address no problems.


Log in to reply
 

Want to support us ?

Join us on :

192
Online

31080
Users

15117
Topics

113744
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.