Big Problems after upgrade from 6.1 to 6.1.1 pc x64

  • Hello everyone!

    My recalbox were running ok on a sd card at x64 PC but after upgrade to 6.1.1 there are two things are not working anymore and dont have idea how to solve it.

    1. It seems the network configuration is missing, none of my two ethernet ports work anymore. They were working with DHCP and Static DHCP fine, but after the update it is impossible to use it, the GUI always reports as "Not Connected". The cable and router configuration are fine because I used the same pc to run windows and it is ok. Something were broken and now it seems the ethernet port is hang with recalbox.

    2. Trying to fix issue Number 1) when quit recalbox with F4, then Alt+F2 to go terminal it is impossible to login, always reports "Incorrect Password" but I've never modified it! indeed when I run the gui and go to security settings I see the default password correct "recalboxroot".

    It is quite a challenge to debug this problem, I had to boot with a linux live usb, mount the recalbox partitions and take a look. I run a e2fsck -fv to check if my partitions were ok just in case and reports everything is fine. The etc/network/interfaces have not inside any info about the ethX adapters, but I guess this version of recalbox manages the interfaces different.

    I want to resolve why cannot login to terminal using the default password which is the same ( just a note, the keyboard is fine 🙂 )

    I hope someone could bring light to these matters.

    Thanks in Advance!!!

  • Well after several hours I was able to discover which is hapenning.

    1. Ethernet problem: After the upgrade a lot of modules stop working on the kernel, so udev process cannot find any adapter. Try to load de module for my net card r8169 but another issue with mii.ko module arised.

    2. Terminal login not working with default password: Well, it was easy, I've installed recalbox in another usb memory and compare files, shadow file was empty in mine. I've just copied the content from one file to other and I've recovery login.

    Network issue is unpractical to continue digging in how to solve it ... I will proceed to install a new recalbox and copy roms/saves/bios...

    It is a shame that update process works so horrible for pc x64, it will be nice to show a warning before proceed.

  • Staff
    Global moderator

    @barsut we are working on making it more stable. There has been changes in the way recalbox connects to the internet, so we hope starting with 6.1.1 everything in that regard will be less of a pain.

  • @paradadf Many thanks for your reply, I'm deeply sorry to criticize in a wrong way the process, it was not my intention, I must say I was a bit tired and asleep but the project and the people involved does not deserve it, hope you can forgive me! 🙂

    Please, anything you need to debug or help about the issue feel free to contact me I will be pleased to help!

  • Staff
    Global moderator

    @barsut don’t worry. Anyone is allowed to give constructive critisism.
    It might be that the team doesn’t always communicate what we have done, are doing or plan to do (although taking a look at gitlab and the changelog does show it pretty well in a technical matter), but who likes documentation? 🙂 Still, we read what (almost) everyone writes and try our best to enhance the experience wirh every new release.

Want to support us ?