Auto Fire setting on Neo Geo



  • Hi all, thanks in advance for taking time to read this.

    I have the Metal Slug games (1 through 5 and X) working on my Raspberry Pi 3 with RecalBox 6.1. I'm using the default core (FBNeo).

    I'm able to access Retroarch (Hotkey + B) and set Auto Fire to On under Options but it doesn't change the behavior of any of the buttons in the game. The other options seem to work fine (Free Play, Setting Mode, etc).

    I tried a workaround (setting the fire button to Turbo under Settings, Input, User 1 Binds and it works until I exit the game and have to set it again next time. I already tried saving a Game Override but that doesn't seem to have any effect.


  • CRT Hero

    @diegus83 when implementing a driver, we declare all dipswitches present on the original system, however sometime the mecanism behind some of them is left over for various reasons, i think that's the issue here : FBNeo standalone already has auto-fire as a frontend feature so that neogeo dipswitch isn't really useful, however the retroarch frontend is lacking that kind of feature.



  • Thanks for the quick reply.

    So if I understand correctly that means that even if I set the auto-fire option manually in the FBNeo .cfg file it won't do anything in Retroarch?

    In that case my best option is trying to get the "turbo" button setting to stick to the ROMs where that feature is useful.


  • CRT Hero

    @diegus83 No, i mean it was never implemented in the backend of FBNeo, which is the part retroarch (which is a frontend) use. The standalone windows version of FBNeo work around this by having a frontend feature, but retroarch doesn't have this.



Want to support us ?

326
Online

82.0k
Users

22.5k
Topics

162.9k
Posts