Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

GPI Case D-Pad not working



  • Hi,
    first of all thank you for the great image for the Retroflag GPI Case.
    Unfortunately, the D-Pad is not working for me with a fresh install of the latest "Raspberry Pi 1 / Pi 0 / GPI Case" image. All other buttons work just fine, even the back buttons.
    I tried a preinstalled image with retropie and the d-pad works fine in there, so no cable or other technical issues.

    I also switched between Axis and Hat mode - without success.

    Any other ideas?
    Thank you!

    P.S.: I'm using a Pi zero w inside the Retroflag GPI case.


  • Global moderator
    Team

    This post is deleted!


  • This post is deleted!


  • Here are some config files. Maybe it helps to find a solution?

    hardware.log
    config.txt
    cmdline.txt
    recalbox-boot.conf


  • Global moderator
    Team

    Hello
    Try
    select+dpad up for 5s
    Or
    Select + dpad left for 5s



  • @acris Select + dpad up did the trick!

    Thank you!



  • my dpad also doesnt work on a brand new gpi-case.

    start/select and the buttons work (i can open the main-menu after bootup), but I cannot navigate the menu using the dpad.

    already tried the suggested select+dpad-up(and left) for 5 secs suggestion but it doesnt work for me. any other suggestions (using Dragonblaze 6.1).



  • @staabm
    Hi,
    I don't know if you solved your problem but I found a way to solve mine, so I share it.
    I experienced the exact same issue: install went fine and all buttons worked. But not the DPad.
    So if every button works, including the shoulder buttons, here is the solution that worked for me: click start to open the settings menu. You want to get to the controllers settings but cannot because of the DPad. Just use the shoulder button that makes the selection jump a few items lower in the list. Use it until you get all the way down to the last item. And then use the other shoulder button once to jump back up little. It should put the selection right on the controllers settings item! You can now click on the button that selects (B I think). And configure a new controller (thankfully it's the first item in the list).
    And you can then map 'up, down, left, right' with the DPad directions. Done.
    Worked for me where all the suggestions above failed.



  • If your Gpi is a newer model, the select button was changed to the start button, so select+DPAD LEFT becomes start+DPAD LEFT.


Log in to reply
 

Want to support us ?

243
Online

78.1k
Users

19.9k
Topics

146.6k
Posts