Recalbox 7.0

Problèmes de Wifi avec Recalbox 6.1 et GPi Case



  • Bonjour,
    Je galère depuis hier soir à faire fonctionner mon GPi Case via le wifi.
    La Recalbox est bien connecté au wifi (adresse ip visible) mais impossible de la voir depuis Windows 10 dans les réseaux.
    Test ping OK pourtant. Accès depuis le webmanager recalbox ok.
    J'ai même vérifier le fichier recalbox-backup.conf (Wifi en FR)
    Pour info, le partage smb fonctionne bien avec mon Superpi connecté en Lan (mais équipé d'une autre distribution).
    Réseau Wifi via Freebox Revolution.
    Testé sur un autre accès internet/wifi même topo mais en tapant cmd explorer \192.201.xx.xxx, j'arrive cependant à accéder à share mais c'est très très long...
    Connexion via winscp Ok mais du coup impossible d'utiliser Skraper car dossiers introuvables sur le réseau.
    Dans l'attente d'une aide de votre part,
    Je vous souhaite une bonne journée.


  • Local Moderator
    Tester

    Salut @bernard-gelot
    Lis ce fil, ça pourrait t'intéresser.



  • Merci @Scavy pour ta réponse, mais malheureusement j'ai déjà gratté du coté du protocole smb de Windows 10 car justement j'ai eu rencontré des soucis avec l'autre distribution sur mon Superpi ainsi que sur mes 2 autres raspberry 3b+ en Openelec.
    Du coup, je vais rester avec Winscp et scraper mes quelques jeux manuellement depuis Recalbox 6.1.
    On va s'adapter tant pis.
    Merci pour ton aide.



  • Bonjour à tous,

    Tout d'abord un grand bravo à toute l'équipe Recalbox. Je suis cette distribution depuis un petit moment déjà, et j'en suis 'globalement' très satisfait.
    Mais si j'ouvre aujourd'hui mon premier message, c'est pour rebondir sur ce souci que j'ai depuis la 6.0, à savoir, moi aussi, un problème de connexion du wifi.
    J'attendais avec impatience la 6.1, pensant que ça allait résoudre mon problème.
    Je sais que c'est un problème récurrent, mais je pense sincèrement qu'il y a un réel problème quelque part.

    Avant de venir me 'plaindre' ici 😉 , j'ai essayé de tenir compte de toutes les précautions qui ont été distillées ici ou là, à savoir , repartir d'une installation propre, et nettoyer mon disque externe contenant les jeux, en ne prenant que les répertoires roms et bios, selon la video tuto récente sur youtube.
    Mais rien n'y fait. Lors d'une installation toute neuve de la 6.1 (j'en suis déjà à la 3e), le wifi semble se connecter correctement. Ensuite, je lui dis d'aller chercher mon disque externe, il reboote, et là, plus rien plus de wifi.
    Je le reparamètre, mais toujours rien.
    En désespoir de cause, j'ai donc édité mon 'recalbox.conf' sur le répertoire 'system' de mon disque externe où il y a mes roms. j'en ai profité pour changer la valeur wifi.region=FR, car elle était restée en US. Mes paramètres ssid et key (non cryptée ... est-ce normal) , étaient bien présents.
    J'ai eu mon wifi qui est revenu ... 1 fois après1 ou 2 activation/désactivation dans le menu. j'ai rebooté, et le wifi a de nouveau disparu.

    • Je tiens aussi à dire que j'ai un NesPi case, mais que je fais attention à ne jamais couper violemment le Raspberry (un PI3B), que je l'éteins donc proprement depuis le menu ES.
    • Autre précision, mon disque externe est en ext4.
    • J'ai vérifié aussi sur ma Box que le canal wifi était inférieur à 12.

    Je me dis que peut-être que je résoudrai mon problème en passant mon disque de roms en FAT32, mais avant de perdre quelques heures à sauvegarder mes Mo de roms, reformatter mon disque puis retransférer mes roms, je tenais à venir donner ici mon témoignage.
    @OyyoDams ... si tu passes par là ...



  • Bonjour,

    Je continue mes investigations sur ce P... de problème de wifi.
    J'ai lu qu'on pouvait forcer le wifi au boot en créant un fichier wpa_supplicant.conf dans le boot de la SD.
    Ce que j'ai fait, mais cela n'a rien donné.

    J'ai aussi essayé un astuce donné par un utilisateur, consistant à modifier le mot passe wifi, fermer pour activer le wifi, puis revenir dans le mot de passe wifi, remettre le bon et fermer pour réactiver le wifi.
    Cette astuce n'a pas marché non plus.

    Je me pose une question cependant, lorsqu'on rentre le nom ssid du wifi : moi je n'ai accès qu'à la configuration manuelle. Est-ce que si le wifi est bien activé, je ne devrais pas avoir la liste des ssid autour de moi ?
    Si c'est le cas, alors cela prouve bien que le wifi n'est même pas pré-activé pour sa configuration.



  • @cyril92
    Bonsoir.
    Ayant l'habitude du duo raspian/raspberry0 pour le travail, j'avais aussi injecté mon fichier wpa_supplicant.conf.
    J'ai cru que mes problèmes venaient finalement de là car au final Recalbox n'est pas Raspian et je suis donc reparti sur une "fresh install".
    Une fois booté, j'ai juste activé dans Recalbox l'option Recalbox Manager puis éteint pour retirer la sd et modifier le fichier "recalbox-backup.conf" de la partition Boot. J'ai juste renseigné mon Wifi SSID, wifi.key et wifi.region=FR.
    Modifications apportées avec Notepad ++
    Du coup, connexions systématiques en Wifi.
    Accès Ok via Recalbox Manager et via Winscp. J'ai par contre laissé tomber le partage smb depuis Windows, vraiment troooooop lent à s'affiché voir refusé.



  • @Bernard-Gelot , merci pour ta réponse.
    Malheureusement ... Recalbox Manager était déjà activé sur ma Recalbox ... et mon recalbox-backup.conf de la partition boot contenait déjà les bonnes infos region, ssid, et key ...
    Je vais continuer à chercher.
    Pourrais-tu me confirmer l'info suivante en tout cas, quand tu cherches à entrer le SSID de ton wifi dans le Menu Réseau de Recalbox, as-tu la liste des wifi autour de toi ? où bien as-tu comme moi 'Saisie manuelle' ?
    C'est cet indice qui me permettrait déjà de savoir si mon wifi est bien déjà totalement désactivé.



  • @cyril92 Hello. Non, j'ai bien le nom de mes réseaux wifi alentour qui s'affichent depuis le menu de Recalbox.
    Ayant une Freebox revolution, j'ai appliqué le réglage suivant dans le Freebox Server : canal 6 pour le Wifi



  • @Bernard-Gelot Hello,
    J'ai beaucoup bricolé sur ma Recalbox aujourd'hui, et elle se connecte au wifi à peine une fois sur 10 en fait, c'est totalement aléatoire et au bon vouloir de Recalbox.
    La fois où j'ai eu le wifi, j'ai vérifié et j'avais bien la liste des ssid autour de moi.
    Quand elle ne se connecte pas, je n'ai que saisie manuelle disponible.

    En fait, malgré le fait que j'ai 'Wifi activé' à 'on' dans le menu, et bien il ne l'est pas, c'est ma conclusion.... mais pourquoi ? Et comment faire pour essayer de le forcer ?



  • Bonjour à tous

    Possesseur d'un GPI Case depuis quelques jours (avec un rasperry zero W), j'ai correctement installé Recalbox, mais il m'est impossible de me connecter au Wifi...
    Lorsque j'active le wifi dans les paramètres réseaux, je ne vois aucun wifi disponible. Je l'ai pourtant configuré manuellement + modification du fichier recalbox.conf mais toujours rien. (Wifi en ON, mais aucune connection)...
    Avez-vous une idée pour régler ce problème ?
    Sinon, savez-vous comment puis-je ajouter des Roms sans passer par le Wifi ?


  • Developer
    Global moderator
    Team

    @fallowgk attend la 6.1.1 qui sort ce soir, ça résoudra peut-être ton problème



  • @oyyodams
    Ah yes merci pour l'info! Je vais donc l'attendre avec impatience !

    Mais pour mettre des roms sans wifi, on peut le faire avec un simple câble micro USB ?



Want to support us ?

166
Online

79.1k
Users

20.3k
Topics

149.0k
Posts