Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Strip led ws2812b et recalbox/hyperion



  • Bonjour/Bonsoir,

    Cela fait maintenant quelques heures que je cherche sur le net différentes façons de gérer mon strip led ws2812b sur ma recalbox, et après avoir essayé chacune des solutions proposées, aucune ne fonctionne avec moi.
    Il n'y a pas vraiment de tuto détaillé pour mettre en fonctionnement tout ce bazar un peu complexe pour moi qui débute dans la raspberry et qui n'as pas de connaissances en réseau.

    La méthode gpio sur le raspberry n'a aucun effet sur mon strip led malgré l'activation des gpio et la bonne configuration de hypercon.

    La méthode arduino les fait clignoter deux fois en blanc au démarrage de l'arduino et c'est tout, rien de plus, avec configuration de hypercon aussi.

    J'ai bien fait attention au nombre de leds de mon strip et à la vitesse de transmission, au pin utilisé pour transmettre les infos, mais rien à faire.

    J'aurais donc besoin de votre aide, si vous avez une solution à mon problème.
    Merci d'avance ;)

    • Raspberry Pi model: 3B
    • Recalbox version (build) : la dernière
    • Matériels (Micro SD, Power Supply, etc.):SD 16gb - stripled alimenté par 5v 3a
    • Manette(s): les boutons / joystick d'une borne d'arcade

  • Staff
    Moderator
    Creator
    Team

    Hello, combien de LEDs tu as sur ta bande... parce que 3a ça me parait court... moi sur ma tv 102cm j'ai du mettre une alim 10A 5v sinon ça passe pas



  • @ian57

    C’est un strip de 144 leds.
    J’ai deja fait tourner des programmes arduino qui la font changer de couleur, clignoter, une a une, toutes en même temps. Aucun soucis d’alimentation.



  • Je précise que mon strip led est connecté sur breadboard.
    J'ai l'habitude de toujours tout brancher sur platine d'essais avant de cabler quoi que ce soit.
    Après vérification, aucun faux contact présent sur la platine mais quand je tripote un peu la résistance, mes deux premières leds s'allument en blanc.
    J'hésite à sortir l'oscillo et à sonder le signal spi parce que je ne vois vraiment pas d'où cela peu venir … :/



  • Personne n'aurait une idée ?


  • Staff
    Moderator
    Creator
    Team

    @herouis jette unn oeil là https://forum.recalbox.com/topic/14199/dtparam-spi-on-hyperion/ et là https://forum.recalbox.com/topic/17892/hyperion-sous-recalbox-v6/ là je suis en déplacement et je n'ai pas le matos pour tester.



  • J'ai regardé les deux liens. Le premier était une découverte, qui n'a pas fonctionné ...
    J'avais déjà visité le deuxième mais cela ne m'aide pas non plus ...
    Je commence à perdre espoir que cela fonctionne un jour ...



  • Up
    Mon problème n’est toujours pas résolu et ce strip led me tiens a coeur. C’est la touche finale d’une recalbox.

    Merci d’avance ;)



  • Personne n’a donc de solution ? ...


  • Staff
    Moderator
    Team

    Bonjour @Herouis
    le seul de la team ayant du matériel à disposition ne sera disponible qu'en novembre.



  • up :) Toujours pas trouvé de solution


Log in to reply
 

Want to support us ?

307
Online

61659
Users

18638
Topics

140042
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.