Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Problème avec Rayman 2 sur PS1 et N64 (Odroid XU4)



  • Bonjour tous le monde !

    Alors voilà, je viens vers vous en espérant que quelqu'un auras une solution, ça fait un moment que je suis dessus, et si j'en viens à vous écrire aujourd'hui c'est vraiment que je sèche !^^'

    Voilà mon soucis, j'aimerais que Rayman 2 soit fonctionnel sur N64 ou PS1 (les deux c'est encore mieux), par ce qu'actuellement c'est pas vraiment le cas, le jeu ce lance mais il n'est pas possible de jouer convenablement, car chaque versions pose un/des soucis différent :

    PS1
    La version PS1 tourne bien niveau image et sons mais le soucis c'est que le jeu crash aléatoirement dans sa version PAL (euro) et une fois sûr deux lors des chargements dans la version US...
    J'ai chercher un peu partout mais aucune solution....

    N64
    Là par contre le problème est encore plus costaux, et la vache, accroché vous par ce que là c'est du lourd :
    -en utilisant l'émulateur Liberto (oui par ce que la plupart du temps, en utilisant les paramètres par défaut, j'ai juste pas de sons sur beaucoup de jeux N64) certains script du jeu ne ce lance pas ! Genre Murtphy ne viens pas me parler et je me retrouve bloqué à l'interrupteur au début du deuxième niveau systématiquement, impossible d'aller plus loin.....
    -avec l'émulateur par défaut ou en utilisant mupen 64 + complet à Glide64MK2 je me retrouve avec une image, le jeu fonctionnel mais aucun sons ! :/

    Es ce que quelqu'un pourrait m'aider ?

    Merci d'avance à tous ceux qui m'aideront à avancer !
    Si l'une des deux version tourne comme il faut ce seras déjà vraiment bien !



  • Vraiment personne pour m'aider ?

    Déjà es ce que c'est normal qu'avec la plupart des jeux N64 j'ai pas de sons avec les réglages par défaut ?
    Par que je me suis naturellement dit "mais pourquoi c'est pas Liberto l'émulateur par défaut?" xD
    Puis c'est connus ce bug de scripts qui ne s’enclenche pas sur Rayman 2 avec Liberto? Non par ce qu'un mec qui connais pas le jeu, il va juste pas savoir que le jeu n'est pas censé se comporter comme ça...

    Par contre le bug pour la version PS1, j'ai vue ça sur un autre forum américain, mais ils n'ont pas de solutions...



  • Je ne peux pas t'aider, en revanche je peux tester sur mon XU4 que j'obtiens le même résultat que toi.
    Cela te permettra d'écarter un problème sur ton installation.



  • @hot22shot Oui ce serais déjà bien ! Je te remercie d'avance !^^



  • @docteurlo, salut de mémoire il passe bien sur la dreamcast, et avec le pi3...



  • @pepito Oui j'ai aussi pensé à cette possibilité mais pour l'heure je préfère rester sur l'une de ces deux version. Maintenant oui, c'est à tester effectivement!^^



  • Alors on avance, j'ai peut être une piste,

    Hier j'ai du remettre à zero recalbox et remettre tous les jeux, suite a un mauvaise manip de la carte SD (j'ai voulus copier les jeux de la carte SD via un disque dur en passant par mon pc sous xubuntu, je l'ai fais 40 fois avec une carte SD ou Recalbox pour Raspbery pi3 était installé, là je l'ais fais deux fois avec ma carte SD ou est installé Recalbox sous Odroid et a chaque fois, l'Odroid n'arrivait plus à booter sur la carte SD après ça, !) mais bon, passons!
    Et là je lance Rayman 2 avec les paramètres/l’émulateur par défaut sur N64... aucun bug de sons.... Quelques imperfection sonore quand le jeu ce lance, mais quelques seconde après tous semble correcte ! =)

    En faite, je ne l'ai pas indiqué mais j'ai comme l’impression que les bugs de sons sur N64 sont intervenue lors ce que j'ai changer l'audio latency de 64 à 128 pour avec un sons correcte (sons bug) sur les jeux PS1en HD... (J'ai fait ça après m'être renseigné sur ce forum même) Et j'ai pus voire que changer ce paramètre n'affecte pas seulement la PS1 mais aussi la snes par exemple... Du coup le problème ne viendrait t'il pas de là ?
    Par ce que, ça aussi c'est un problème : pourquoi je ne peut pas accéder aux réglages de l'émulateur n64 par défaut en faisant hotkey+X(croix) comme sur PS1 ou autres ??? Pour la N64 c'est possible seulement sur Liberto...

    Du coup on avance,

    Maintenant bizarrement j'ai pas encore eu de bug de sons avec la PS1, alors que j'ai déjà fais mes réglages pour la passer en HD ! Quelqu'un comprend quelque chose ? Genre les bugs de sons vont intervenir plus tard ? Oui par ce qu’actuellement j'ai encore l'audio latency sur son paramètre par défaut (64)....


  • Staff
    Moderator
    Team

    Bonjour @DocteurLo
    je ne pense pas que tes problèmes soient liés aux paramètres que tu utilises pour la ps1
    c est un core retroarch alors que l emulateur n'en est pas un, c est un emulateur standalone.

    si tu modifies un paramètre général dans retroarch et que tu écrases la configuration par défaut de retroarch par défaut
    il y a des répercutions sur les autres cores....

    L emulation N64 est capricieuse, il ne faut pas espérer des miracles.

    Pour rappel, il faut uniquement transférer les roms et bios d'un rpi vers un odroid et vis et verça
    pas de fichiers systèmes -> plantage CQFD

    A noter que certaines roms EUROPE/France peuvent être buguées alors que les versions UK/USA ne peuvent ne pas l'être et vis et verça



  • @acris Oui je crois avoir tenté de copier un dossier système effectivement...
    Maintenant j'ai quand même l’impression que sur pour les SD destiné au Raspberry Pi c'est moins capricieux quoi...

    Pour Rayman 2, N64 j'ai aussi essayé avec la rom US aussi et le résultat est le même.... =/
    Et oui l'émulation N64 est compliqué je confirme... mais avec Liberto j'ai beaucoup moins de problème d'émulation je trouve...

    Mais par exemple, ce bug de crash dans la version PS1 de Rayman 2, maintenant que je l'ai signalé, c'est possible que ce soit corrigé dans des futurs MAJ par exemple ?


  • Staff
    Moderator
    Team

    @DocteurLo
    nous ne sommes pas les développeurs des core libretro , nous faisons simplement des intégrations.
    Si le problème se situe sur le core libretro, il faut ouvrir une issue sur leur repository.

    Quand à Odroid, la team va travailler à l'amélioration de celui ultérieurement post 6.1



  • Je comprend pas ce que vous entendez par "intégrations". Intégré c'est genre "ajouté" c'est ça ?


  • Staff
    Moderator
    Team

    Oui c'est ajouté compilé le core pour l utiliser dans retroarch. Nous ne développons pas les cores/emulateurs.
    https://github.com/libretro



  • Je vois....



  • Alors... Vous savez quoi, là j'ai du sons sur Rayman 2 (avec l'émulateur par défaut)... o_o
    Non mais je vais finir par croire que c'était juste le fait d’enchaîner les jeux N64 à la suite qui ont fait que l'émulateur c'est mis a déconner ! Oui c'était histoire de voire si tous les jeux de la liste étaient fonctionnel.

    D'ailleurs j'ai oublié de dire un truc, sur l'autre installation, j’avais changer un paramètre dans l'interface recalbox, j'avais changé l'audio de "Auto" à "Odroid quelque chose" xD c'est censé changer quelque chose en jeu ça ?



  • Du coup, c'est un bug a signaler ça non?^^

    Au passage j'ai testé la version DC, et elle tourne impect ! Sauf un bug ou tous les éléments 2D sont entouré d'un carré, je sais pas trop comment corriger un tel bug, mais j'imagine que ce sont sont genre de défauts que l'on verra moins quand recalbox sera optimisé pour Odroid XU4 non ?

    PS: es ce que quelqu'un aurait une adresse mail pour que je puisse signalé les bugs que j'ai trouvé sur l'émulateur PS1 aux concepteurs de l'émulateur justement ???^^'


  • Staff
    Moderator
    Team

    Bonjour @DocteurLo

    pour ouvrir une issue chez libretro PSX : https://github.com/libretro/pcsx_rearmed/issues

    j'ai dû mal à suivre tes problèmes un coup N64 un coup PSX,



  • Tous ce qu'il y a à comprendre c'est qu'avec Rayman 2 :
    -Sur PS1 le jeu crash aléatoirement
    -Sur N6 durant un bon moment je n'avais plus de sons du tout, mais j'ai résolu le problème.

    @acris j'ai signalé le problème a l'adresse que tu m'a envoyé ! ;)



Want to support us ?

Join us on :

115
Online

52342
Users

17757
Topics

133608
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.