Recalbox 7.0

Building Recalbox fails at sameboy



  • Hello, I'm trying to build recalbox from source using instructions at https://gitlab.com/recalbox/recalbox

    I'm doing this to get Moonlight Stream working, which does not work in 6.0, but has been fixed in preparation for 6.1.

    I have tried this on two different linux systems, one running Pop_OS! and one running Ubuntu 18.04, and got the same error:

    /usr/bin/install: cannot stat '/home/danderson/recalbox-rpi3/output/build/libretro-sameboy-9ab7f4f1d98006d57d7f058d33792598972f27d0/build/bin/BootROMs/*.bin': No such file or directory
    package/pkg-generic.mk:304: recipe for target '/home/danderson/recalbox-rpi3/output/build/libretro-sameboy-9ab7f4f1d98006d57d7f058d33792598972f27d0/.stamp_target_installed' failed
    make[1]: *** [/home/danderson/recalbox-rpi3/output/build/libretro-sameboy-9ab7f4f1d98006d57d7f058d33792598972f27d0/.stamp_target_installed] Error 1
    make[1]: Leaving directory '/home/danderson/recalbox-rpi3/buildroot'
    Makefile:25: recipe for target 'buildBR' failed
    make: *** [buildBR] Error 2
    

    Just a few lines earlier, this was called:

    rm ../libretro/cgb_boot.c ../build/bin/BootROMs/cgb_boot.bin ../libretro/dmg_boot.c ../build/bin/BootROMs/dmg_boot.bin ../libretro/sgb2_boot.c ../build/bin/BootROMs/sgb2_boot.bin ../libretro/agb_boot.c ../build/bin/BootROMs/agb_boot.bin ../build/bin/BootROMs/sgb_boot.bin ../libretro/sgb_boot.c
    

    A more complete paste is here: https://pastebin.com/DUy4Ndbn

    Reading a bit on the Discord, somebody was saying that changing their docker image to 4 cores fixed it, but it did not for me.

    To me, it looks like the makefile is deleting files that it then tries to use, and I cannot figure out which makefile is responsible. What steps can I take to get it to finish the build process?



Want to support us ?

137
Online

79.1k
Users

20.3k
Topics

149.1k
Posts