Problem with Recalbox 6.0 and USB

  • Hi everyone!

    Since a few days ago I had the version of Recalbox that was before 6.0. Today when I switched on the Raspberry Pi 3 it only appeared the internal file, not the external one (I have a 500G HDD). I have restarted several time and there was no luck, so I have changed to the Recalbox 6.0 on the internal and the external file.
    When I tried to add it to the external file, at the SSH part it gives me an error all the time: at the part
    of the input ./ list they appear 2 external devices: RECALBOX and ROOT. I thought that ROOT was the correct one, I continued with the steps but it told me that the files did not exist. I tried with RECALBOX and neither.
    I have format again the HDD (it also appeared that the capacity was lower that 500G so I had to repair it so it showed the correct one), I have added the Recalbox 6.0 for the Raspberry Pi 3 with the Etcher and then used the Putty and tried to sync it again but it does not work and I don't know what I'm doing wrong... Could someone help me with this, please?

    Kind regards,

  • Tester
    Global moderator

    @gon13 I do not use an external hard drive, so I'm not sure, but from what I see you are the only user with this problem, which indicates that either you are doing something wrong, or you have a hardware problem.
    I think it's possible that you have a problem with the external hard drive, or that you're formatting it wrong, because you said that you had a problem with the available HD space.
    I do not understand how you are trying to use this external HD, basically just need to connect in the recalbox, and, in the emulationstation menu, change the storage from internal to external ...

  • Thank you @Zing for the answer!
    The thing is that until a couple of days the external device worked perfectly... I have read that maybe it is because I should change the sync speed of the device with the Putty program because normally HDD with high capacity are slower, but instead of that I profit to update to 6.0 Blazedragon.
    I tried to format again and write the Recalbox 6.0 with the Etcher it seemed to work, but when I pluged the hard drive to the computer it does not show the share file 😕

  • Tester
    Global moderator

    @gon13 I do not know if it's because of the translation (English is not my native language), but I still do not understand perfectly what you mean.
    Are you using an Rpi3, you're installing Recalbox on an SD card, and using the external hard drive as the ROMS (SHARE partition) storage, correct?
    As I said earlier, I do not use external HD, but from what I understand, you simply format your HD as FAT32 you could use it on Recalbox and it be recognized by Windows.
    At least on the SD card it is not possible to view the SHARE partition on windows because it is formatted in EXFAT4 (if I am not mistaken), and windows does not recognize this format, but FAT32 is possible to use in both linux and Windows.
    When you installed Recalbox, did you wait for the first boot to finish? It is a common problem not to let the system create the SHARE partition because it takes too long to boot the first time, and people confuse it with a crash...

  • @Zing Sorry if I don't explain better ^^U
    It is correct Rpi3 installing the Recalbox 6.0 through Etscher on an SD card and using the external hard drive for bigger roms (N64, PSX) as it has more space.
    For the SD card everything is correct, the thing is that for the hard drive when I put the Recalbox 6.0 with the Etscher sometimes the Rpi 3 does not recognize it. Also I was planning to copy the backup that I made with all the roms for the hard drive, but when I plug it to the computer it does not appear the Share file as it always appeared before I do not know why so I can't copy them like I used to do.

    On my computer I can see the SD card with the recalbox manager and like a normal file connected to the computer with all of the files.

    So, in summary I need to fix in the hard drive a way that the Recalbox 6.0 appears like before to go inside each of the files (bios, Roms---> SNES, etc) to copy the games that I have saved and I need to fix it so everytime I put on the Recalbox ANYEXTERNAL appears the files from the hard drive and not the ones on the SD card.

  • Tester
    Global moderator

    @gon13 I understand now, but to rule out the possibility that you are doing something wrong, format the external hd in FAT32, and follow the instructions:
    If it still does not work, test on another device, for example a pen drive.

  • Hello @Zing and thank you for your help!

    I have format the external hd, copy again the Recalbox 6.0 and the problem is that when I restart it it does not copy the share file and the others on the usb and it changes something on the device that appears with the wrong capacity.
    I'm going to try to install Batocera to see if it is something of this device or not and at least try to play to something with it.

  • Tester
    Global moderator


    copy again the Recalbox 6.0

    How did you copy Recalbox 6.0 again?
    On the external HD it should only contain the SHARE partition, if you format in FAT32, rename it to "SHARE" and copy the contents of the SHARE partition, then go to the emulationstation menu and change to ANY EXTERNAL, should work.
    Batocera is another system, based on Recalbox, but it is another system, administered by another team, and you will not have support of this Forum if you install Batocera.

  • Hello @Zing !

    Sorry to bother you again ^^U
    I used Etscher to copy the Recalbox. I have tried your sugestion and it does not work.
    I tried another usb and it seems to load, but when I put in the computer it doesn't appear the share file. I put again on the recalbox and it appears: internal, any external, recalboox and boot, when I select boot it seems to load but it has frozen :S

  • Tester
    Global moderator

    @gon13 And why do you select "boot"? You need to select "any external", and to be recognized in windows, you need to format in FAT32 (or NTFS, but it is slower for RECALBOX).
    Incidentally, you can not have a "boot" and "Recalbox" partition on your external hard drive or pendrive, you should only have the "SHARE" partition, if you have the other 2 partitions this indicates that you are installing the whole system on HD external, and is not using as ROMS storage only ...

  • @Zing I made it!!! 😄
    I had to change to FAT32 (it was in NTFS and didn't recognize it) and also create the share folder and now everything is perfect.
    Thank you so much for your help and your patience!!

Want to support us ?