IPac2 not working with Recalbox 6.0

  • Has anyone managed to get an Ipac2 working with v6.0 ?

    After some struggle configuring version 4.x, some two years ago (see this topic), I got my Ipac2 working perfectly.

    It also worked fine with versions 18xxxx.

    But once moved to v6.0 and after going again through the same tutorial, it looks like the new version of Recalbox broke something, as now my Ipac2 is not detected anymore. Nothing is visible/detected inside EmulationStation.

    Any ideas?



  • Banned

    @jonas I seem to remember that someone managed to make it work in 6.0, but I'm not 100% sure.

    I wouldn't be surprised if it's broken though, the developer who knew this part well (and coded it) has left the team a while ago, long before 6.0

    EDIT : no the last guy I spoke with about IPAC was on 18.* something too

    My bartop is using IPAC2 too, but I never updated it from 4.0... and I guess I won't now 😉

  • @voljega Damn, I have an IPAC2 and was hoping to use it in RecalBox. Pity.

  • Banned

    @retrofuture it might be fixed,just need to retrieve the original commits

  • @voljega , @retroFuture

    I went through the mini-howto again, and tested with evtest . It detected the two sets of sticks+buttons provided by Ipac2, each one registering separately.
    It's just EmulationStation which does not detect two X-Arcade controls out of the box, as it did before 6.0. It looks like now we have to manually remap the two Ipac2 sticks+buttons inside EmulationStation, in order for these to get registered properly.

  • Banned

    @jonas any controller needs to be remapped usually... So with remapping it works ?

    You still add to crete the fake files right ?

  • @voljega, @retroFuture

    Confirmed, it works exactly as in 18.xx.xx and 4.x .
    I got confused because my standard gamepad was detected "as is" and EmulationStation immediately shows it in the list of available controllers. But for the IPAC2, after going through the creation of the fake files, we still need to invoke and conclude the remapping in order for the two IPAC2 built-in controllers to be displayed in that same list!...



  • Banned

    @jonas ok I see thank you for the feedback !

  • @jonas Hey there, could you please describe a little more detailed what your steps where after creating the fake failes? I am struggling with the same issue, old 4 and 18.x.x versions were fine, current v6 not. Also tried it with carcade, resetting the arduino based usb encoder to default keys, rewiring all buttons accordingly, but that does not work 100%. Some buttons, besides being totally separate buttons and keys, trigger both p1 and p2 movements, some don't work at all. Controller gets detected as "keyboard" - before v6 it was the device name (usb-Arduino_LLC_ArcadeForge_Key_Strike-if02-event-kbd) after creating the fake file in /share/system/configs/xarcade2jstick ...

    Looks like you've git it resolved so a little help would be awesome.

    Here are some more infos (https://forum.recalbox.com/topic/18650/recalbox-v6-usb-keyboard-encoder-not-working/2) in case a dev is reading this.

  • Hi @SmashDde

    I read through your posts in the other thread, but I have no idea how to help you. In my case, getting the ipac2 to work with 6.0 was just a matter of creating the correct dummy file and remapping the P1 controller in RecalBox, using the standard procedure inside EmulationStation (pressing a button to detect, then filling the remap table). Not much to describe here.

    For the record, I also own a DualStrike v3 single player encoder, from ArcadeForge, and it also works fine with Recalbox, using the same X-Arcade "driver".

    I remember having some problems with "disappearing" buttons, but these were due to bad wiring/soldering/terminal contacts near the iPac2. After checking my wires, I retested the encoder in Windows, using a proper keyboard tester utility, and made myself sure the encoder, wiring, P1/P2 buttons and sticks really worked as intended.

    Once hardware problems are totally sorted out, if you still have your encoder detected as keyboard, then the dummy file may be incorrect. In my case, I had two options for the filename, but only one worked - see the mini HowTo for details.

    If this still does not work, the only conclusion is that we have a encoder incompatibility with Recalbox... that would be really bad luck 😞



  • @jonas Thanks so much for taking the time to take a look and answer. I was hoping for "oh, I have made a remap cfg in folder so and so", not using the GUI wizard, but sadly it's not a step I missed. I will try to make the dummy file via terminal instead of copying it over via Samba/FTP, maybe it's a difference, although the user rights seemed to be the same. I'll reset the keystrike USB encoder once again, check everything, maybe something wasn't just exactly right, who knows. Anyway, thanks for your post, hopefully I'll get it working... Building a nearly 4-figure bartop and end up using it with a DualShock 3/4 or 8bitdo's SF30 Pros wasn't exactly the plan. 😄

  • Holy sh...! It's alive again! I cannot pin the reason down though, but I'm certain it was something I made wrong again and again. Maybe sth. to do with the windows ssh shell (didn't want to set putty up because I find that confusing). Anyway, thanks so much for guiding me through. 🙂

  • @smashdde, good to know!

    From my experience, the troubles with the encoders have always been due to tiny, f***ing, missed details, from taking wrong shortcuts, and so on... 8-P



Want to support us ?