Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Particular setting not being saved per game override.



  • @zing I just checked and "save configuration on exit" is actually disabled.



  • @lumbeechief081 But did you test what I suggested?



  • @zing Yes that is what I already tried before making this thread and what didn't work. Quote: "The way I go about only having the 3 Zelda games just use color correction disabled is to save game override. Only problem is when I save game override it also saves it to the core which in turn effects all other gameboy color games." I basically already did what you suggested. You must didn't read my thread thoroughly and didn't think what I mentioned is basically the same thing you are suggesting.

    1.Save game override with color correction disabled for Zelda Link's Awakening.

    1. Start different game such as Shantae and color correction is disabled.
    2. Save game override with color correction enabled for Shantae.
    3. Start Zelda Link's Awakening again and color correction is enabled.


  • @lumbeechief081 Sorry, but you say that saved the settings of 1 game is not the same as you say that did the test saving in 2 games, there is much difference, and I do not have to guess anything, I read your topic and this information only is available in your last reply. You need to be very clear if you want help, and you could try to be kinder to whoever is trying to help you.
    Which version of Recalbox are you using? (please say the version, do not say "last") Did you do a clean install, or upgrade?
    Did you set up the system from an official image, or downloaded a ready image from the internet?
    Did you make any significant changes to the system?
    Do you have another SD card to test if with a clean installation of the latest official version this problem also happens?



  • @zing I'm so confused right now. I said save game override not save game. I'm using a fresh installation of 6.0-DragonBlaze from the official download page https://archive.recalbox.com/ for my Pi 3 B+.



  • @lumbeechief081 I asked 5 questions, you answered only 3, if you want help, answer all the questions:
    Did you make any significant changes to the system?
    Do you have another SD card to test if with a clean installation of the latest official version this problem also happens?



  • @zing
    Quote: " I asked 5 questions, you answered only 3, if you want help, answer all the questions:"

    Well, I actually overlooked those other 2 questions because I find them irrelevant. I didn't even see them when reading your paragraph. I'm a fast reader. If I made changes to the system that would cause this issue I'm having I wouldn't be creating this thread. I would already know what the problem is and what caused it. I have enough knowledge to know what I can and can't fix by being an IT alumnus before I actually have to seek outside help. I know when something is a user error and I know when something is a bug and is out of my hands. If I made a significant change to a system I know how to backup and restore an image or restore point. I'm 23 and I have been using computers and troubleshooting them since I was a kid. Sometimes I just feel like the questions people ask me on forums think i'm an illiterate with computers. Not trying to be rude but that's like calling tech support and you get stuck with a level 1 when you need to speak to a level 2 or 3.

    Did you make any significant changes to the system? Heck no
    Do you have another SD card to test if with a clean installation of the latest official version this problem also happens? Already done this



  • @zing Sorry if you don't know what is causing this issue. Can you at least tell me if it is possible to add "color correction = disabled" to the .cfg of the game? That way if I want color correction disabled/enabled I can just save game override for a particular game and then manually add "color correction disabled/enabled" to the .cfg of whatever game.



  • @lumbeechief081 No, you not "overlooked because you considered the questions irrelevant," and you're not a "fast reader," you're just lazy, and you think the world revolves around you, and the way you want it.
    Do not you want to be rude? DO NOT BE! You're being rude and overbearing with the one person who tried to help you. I'm not your employee, you're not paying anything, so DO NOT COVER LIKE IF YOU WERE MY BOSS, you do not rule me.
    Do you really think it's the only one in a retrogames forum that uses a computer since it's a kid ???? I already did emulation when you were not even crawling.
    You are not stuck in a level 1 bracket, but your communication skills are limited, so people need to ask more than once so that you can give them an answer that will clarify what you want.
    I ALREADY SAID, BUT YOU IGNORED: I DO NOT HAVE TO GUESS ANYTHING! Say all the information, be clear, and gentle, being stupid is against the rules of the Forum, but you should not have read the rules, because it is "fast reader" (LAZY).

    BUT, I did some tests here and I found a possibility for what you want, I need you to test:
    Start the game you do not want to have "Color correction", press Hotkey + B, go to "Options", disable "Color correction", and in this menu click on the first option: "Create game-options file", this will create an .opt file with the name of the game, in the path:
    SHARE\system.config\retroarch\config\Gambatte
    and this file has the line:
    "gambatte_gbc_color_correction ="
    Take the test, and come back here to say whether it worked or not (but do not be rude).



  • @zing Jesus Christ!! No need to get so defensive.

    Quote: No, you not "overlooked because you considered the questions irrelevant," and you're not a "fast reader,"
    Actually i'm a fast reader and I did overlooked it. You're not me and thus you can't say something that's isn't true.

    Quote: You're Lazy.
    Somewhat, after all I should have figured out the "Create game-options file" existed, but I guess I was impatient and overlooked it and decided to seek outside help. If I would have been more patient about getting this issue fixed I'm sure I would have came across the "Create game-options file" but instead I was lazy and created a thread. What's f****** odd about Retroarch in the first place is the need for so many configs. Logically speaking "Save Game Override" should cover everything and there shouldn't even be the need for a "Create game-options file".

    Quote: Do not you want to be rude? DO NOT BE! You're being rude and overbearing with the one person who tried to help you. I'm not your employee, you're not paying anything, so DO NOT COVER LIKE IF YOU WERE MY BOSS, you do not rule me.
    Did you read? I said "Not trying to be rude" but sorry it came off that way. Also where did the whole employee idea came from? I sure wouldn't want you to be mine with the way you came off on me with anger. I would want a employee who can handle things better in a more calmly manner.

    Quote: DO NOT COVER LIKE IF YOU WERE MY BOSS, you do not rule me
    Where did you get such a wacky idea?

    Quote: Do you really think it's the only one in a retrogames forum that uses a computer since it's a kid ???? I already did emulation when you were not even crawling.
    Well I trust that you're older than me? Well you sure didn't come off that way. You should have handled things in a less childish way instead of ranting.

    Quote: BUT, I did some tests here and I found a possibility for what you want, I need you to test:
    Start the game you do not want to have "Color correction", press Hotkey + B, go to "Options", disable "Color correction", and in this menu click on the first option: "Create game-options file", this will create an .opt file with the name of the game, in the path:
    SHARE\system.config\retroarch\config\Gambatte
    and this file has the line:
    "gambatte_gbc_color_correction ="
    Take the test, and come back here to say whether it worked or not (but do not be rude).

    Yes I very much appreciate the help, thank you. This was the solution I asked was possible in my very first paragraph "How do I get around this? I check the .cfg in Gambatte and I don't even see the color correction listed. How do I add it?"
    Apparently such a option couldn't even be added to the "game override config" because apparently there is a freaking options file for that setting. One would expect "save game override" to handle every setting but apparently not. And because I was impatient I overlooked it and was lazy and instead decided to seek help online.

    Quote: If my answer was helpful, please give a positive feedback by clicking the up arrow below the answer, next to "quote".
    Sure I guess you deserve it. You did help me after all.


Log in to reply
 

Want to support us ?

220
Online

61698
Users

18638
Topics

140044
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.