Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

RecalBox 6 crashes instantly to the console



  • Hello.

    I've recently updated to the newest Recal Box 6. I flashed my hard drive like always and booted up RecalBox. After selecting first option in the bootloader RecalBox splash screen showed up and then list of available systems. Then second after music started to play EmulationStation crashed, leading me to the console. There is an information about saving AlsaMixer settings and saving recalbox.conf file in the log and nothing after that.

    I'm using x86 version of RecalBox. My rig is based on HP business computer.

    I hope you can help me out.

    Oh, and I flashed my drive via Ubuntu LiveCD, which I've never tried before. Maybe there's a problem with permissions?

    For testing purposes I've executed chmod 777 on all files and folder and there's no difference.

    I've booted up RecalBox in verbose mode. There's an information about es_systems.cfg missing and about underrun (snd_pcm_recover). Then there's fatal IO error 4.



  • hi . i think rb 6.0 x86 has problem . i have same problem . x64 work ok . i checked x84 in 3 syste (c2d pc - i3 pc - i5 laptop) same problem . emulationstation came up for 3 sec then crashes to console.
    there's fatal IO error 4



  • Hi,

    I've just try recalbox for x86 and I have the same issue like you. Have you found a solution?
    I've resolved the es_system.cfg error to copy it from /recalbox/share_init/system/.emulationstation/ to /recalbox/share/system/.emulationstation/



  • I was able to reproduce the problem (same error messages) on an Asus Eee PC X101CH which has an Intel Atom N2600 CPU that supports EMT64 by default, but Asus disabled this in the BIOS, so I tried the latest x86 build for Recalbox 6 and it crashed just like it was described in this thread.

    (Luckily, I was able to find a BIOS mod which re-enabled EMT64 support and after that I was able to boot the x64 version of Recalbox 6 on the very same device.)



Want to support us ?

199
Online

62353
Users

18667
Topics

140203
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.