Yet another PS4 controller that can't be paired via bluetooth

  • hello, first of all i apologize if my english isnt perfect and if i do any mistake.

    I've install recalbox v4.1 (official) on my new raspberry Pi 3+ by flashing an SD card. Installation was fine, everything work fine. I tried the virtual Pad and using an official Ps4 controller via USB and no problem.

    Then I tried to pair the controller via bluetooth and the problem began. It seems that i can't pair it automaticly. It detects it on the list of device, but when i choose it , it says "impossibe to pair controller" right after 1-2 seconds.
    I tried with the controller config on "official" and "bluez" nothing change.
    I tried that method step by step
    but doesn't work either.
    I've done it multiple time, changing the controller config, I deleted the already paired controller (even if they were none), pushing "share" + "select" before and after searching for a controller on the menu.
    Then I tried that method
    I am on window so I used Putty, accessed to the root and used bluetoothctl. I could succefully connect the controller using that method, and everything seems fine on the ssh, no error.
    But when I went back on recalbox, the controller, even paired (the light was shining continuously), was not working.
    I could not control the menu nor playing in game. I tried to config the button but none worked, The weird thing is that i can chose the controller as a Player controller and I know it is detected by recalbox, but the input from the controller seems to be just ignored. Now i am stuck with a paired controller that cannot control the recalbox.
    I looked long for an answer but couldn't find one.
    I know i am not totally understanding everything i tried, so I did not attempt anything i wasn't sure that was different from the method shown.

    Thank you for taking your time to read and thank you even more if you could help me

    PS: I think the PS4 controller is the v2

  • Staff
    Global moderator

    Hello @Galaxie18
    Are you sure recalbox 4.1 ?
    Because it s very very very old version.

    Please check your version in recalbox system

  • @acris sorry i don't know how i messed it but i am actually on 6.0-rc2 , I just did the upgrade

  • Staff
    Global moderator

    Have you reset your PS4 gamepad ? it's important if you use your gamepad on PS4.

  • @acris I did every explained in the first method, including reseting the controller bluetooth history. I event disconnect the ps4 just to be sure

Want to support us ?