Grandia: Insert Disc 2.....and YET!?

  • Hi everyone. Here's my problem:

    Playing Grandia on my Rasp 3, i quickly discovered i couldn't save on the virtual memcard. Kinda surprised me at first, since the other games can save normaly just fine, so i used savestates. I worried about the fact that there were two discs, and swapping from one to another meant using a save. A REAL, NORMAL save. I then searched (not deeply enough, maybe?) a way to make it work anyway, changing the name of the savestats to make it match the name of the disc 2 and stuff and also found the "Hotkey + whatev" opening the virtual tray, putting the next disc, then closing the virtual tray, and voila! It works.....not.

    The situation is the following: At the end of the disc 1, i'm told it's....the end of the disc 1, and i MUST save. No way around it, it leads to straight to the saving menu. So here i save, looking at the memory card trolling me with a "saved files" with no info inside of it, and no way to load it.....and only THEN it allows me to get out of that useless menu.
    And i'm stuck with a screen: "Insert disc 2, then push Reset". And as i do that? Well it resets alright! And keep zero data of anything i "saved"! And loading states doesn't change anything either.

    Not to mention that i initially had the two files (Grandia disc1, Grandia disc2) on my Rasp, but also converted them into a pbp to make it a single file.....and it changed nothing. Opened the virtual tray, put disc 2, closed the virtual tray......

    So it's time for me to ask for your guidance. Is there something i missed in the manip? A step i overlooked?I'd be thankful for anything who would help me to make it work!

  • Global moderator Translator
    Translation Master
    Global moderator

    @edenlegaia Hello!
    I do not have this game, nor do I have this problem, but did you follow all the steps of the wiki?

  • The best way to use multi disk games in psx is described here (see Definitive mode):
    This works perfect!!

    I have Grandia and following that guide I have this files:
    Grandia (E) (Disc 1) [SLES-02397].bin
    Grandia (E) (Disc 1) [SLES-02397].cue
    Grandia (E) (Disc 2) [SLES-12397].bin
    Grandia (E) (Disc 2) [SLES-12397].cue
    Grandia (E) [SLES-12397].m3u

    The text of Grandia (E) [SLES-12397].m3u file is this:
    Grandia (E) (Disc 1) [SLES-02397].cue
    Grandia (E) (Disc 2) [SLES-12397].cue

  • for the saving problem, do you have the correct bios file in the bios directory ? If you can't save on memorycard, most of the time, it means that the bios is not correct.

  • I looked at the Definitive PSX seems to say what it does, but not how i'm supposed to make it work.

    As for the bios, each time i launch a game, it says "NO PLAYSTATION BIOS FILES FOUND" or something. Funny thing is, it never mattered when it came to save in "mono disk" games like Breath of Fire 3/4. Not once have i used savestates for those games. Grandia is, so far, the only one to make me do so....and the first Multi Disk game i'm playing on my Rasp 3.

    What's strange about the bios is, i've put them into the right directory, made sure they were rightly written, and the md5 was right too for each of them. For some reason i've yet to know, Recalbox just....doesn't seem to care about their existence. If that damn program recognizing AND ACTUALLY using a bios would be the key to finally use normal memory card saving system, that'd be nice and resolve the issue of having to go through five hundred guides and file dissection/recomposition for multi disk games.

  • Global moderator Translator
    Translation Master
    Global moderator

    @edenlegaia You claim to have the correct BIOS, but did you verify this in Recalbox Manager?
    I've seen more than one case where the person had the correct BIOS, and in Recalbox Manager he accused the BIOS is missing, because these files are case sensitive, the solution was simply to rename the file, maybe it's your case.

  • I'll verify that. In case it needs a renaming, what would you suggest? SCPH1001 didn't work, scph1001 didn't either.

  • Global moderator Translator
    Translation Master
    Global moderator

    @edenlegaia It has to leave equal to what is requested by Recalbox Manager, this BIOS if I am not mistaken is in upper case.
    But it's not just this PSX BIOS, I can not remember the name of the others, but I think the others are in lowercase.

  • @edenlegaia said in Grandia: Insert Disc 2.....and YET!?:

    I'll verify that. In case it needs a renaming, what would you suggest? SCPH1001 didn't work, scph1001 didn't either.

    the .bin extension is also case-sensitive i think.
    So the file has either to be named SCPH1001.BIN or scph1001.bin

  • I tried both before, writing both the scph and the bin in both cases.

  • Global moderator Translator
    Translation Master
    Global moderator

    @edenlegaia But did you check into Recalbox Manager? I think it's not just one PSX BIOS, I think there are more files.

  • Here i am, sorry for the lateness. Tons of things to do x_x
    I got into Recalbox Manager, to find out the BIOS weren't they were in a "psx bios" directory. Had to get them out of there and the Manager finally found and validated them (as it told me how to write them as well: the 1001, 5500, 5501, 5502).

    That solves the BIOS mystery, as i no longer have a "NO PLAYSTATION BIOS FILES FOUND". Alas, tho i tried to save, it didn't save anything. I tried to make it work using the usual multidisk method (eject disk, insert disk, close tray) and it still doesn't work.

    Was it because i've put all four BIOS? Or the game picks what is supposed to be good for it? Does anyone have any idea how to make it work.....if it's even possible? I mean, i don't really want to believe i won't be able to play multi disk games on Recalbox, and i probably won't start another game after playing so many hours for naught, if it IS for naught.

  • Global moderator Translator
    Translation Master
    Global moderator

    @edenlegaia I do not know what you did wrong, but I downloaded this ROM just to test, and I managed to save it normally.
    Make sure you do not have the SD card full, and I recommend using a USB adapter to try to recover the SD card on a Windows computer because it may have corrupted some data.
    If that does not work, try to do a clean installation of Recalbox. After doing the installation clean, copy only the BIOIS and this ROM, if it does not work, you definitely have a problem in the ROM (since the BIOS you have already checked, and I can save normally, it is not a problem of the game itself).

  • Ok. I DON'T UNDERSTAND what went wrong or right or whatev but.....SOLVED.

    Yep. Solved. Just like that. Maybe making sure the BIOS mystery "unlocked" it without me noticing, but the Memory Card saves.....kinda works now. Except when i save, i don't see it saving. Seeing no differences, i thought it still didn't work.

    Yet, this morning (yeah, two weeks later.....the situation made me kinda mad. Plus, got shittons of things to do), i got two "clean" Grandia isos and put them in my Rasp 3. Turned out it couldn't save and change disks, or so i thought. Of COURSE it wouldn't! Ha!

    And then, i thought i could maybe try to do a Clean Start, saving as soon as possible right at the start of the game, in Parn. In a hurry, i chose "Load Game" instead of "New game". And oh, what do you know, THERE WAS A SAVE FILE! And telling me i was on the wrong disc!

    So, i ran the Disc 2, and....the save was there. As if it was waiting since forever for me to realize i was trying to find a solution to a problem that didn't even exist in the first DAMN F.....LYING PLACE!

    So, my impressions on this? Having clean, recognized bios, without necessarily clean isos (still running "modified" ones, for the voices...) still makes the Memory Card save files stealthy, yet they're there when you load them. I don't know if that madness will be there on all Multi Disc games, but well.....that's how it is.

    Anyway, thanks for all the replies. It was nice to have help and i'm pretty sure the BIOS mystery was the key of this. Even if it wasn't, i wasn't sailing alone on those awful seas, so, many thanks!

  • I managed to switch from CD1 to Grandia CD2.

    It was obvious from the beginning. It's been several months since I spent 2-3 hours trying to switch to CD2. But for this game it is absolutely necessary to be able to make an ingame backup to achieve it. One post in particular gave me the bug but I did not understand it.

    For the game to be fully compatible it was obviously the bios playsatation in the recalbox. For a novice explanations on this forum are almost always evasive on the subject and does not allow to clearly understand that it is not original in the recalbox. You have to add it manually and download it on the net !!!!

    At the launch of the game it says 'no bios files found' the game runs without but with gaps, as the backup ingame that did not work. After downloading the bios and copying it to the bios directory, the launch of the bios no compatibility message did not appear. So I load my state and make a backup in the game (ingame) and this time it worked.
    At the time of changing CD I made a save state at the time of the last backup of CD1 and I renamed GrandiaCD2. I launched Disc2 and loaded the state to the loading screen so I was able to backup from CD2 with my CD1 progress. And finally after the famous 'verification of data' it has correctly loaded. I restarted the game and I loaded my game normally. Finally whew it was finally possible to move to CD2.

Want to support us ?