Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

February 2019 Beta Version

  • Unfortunately I can not launch any games. Black screen and then it goes back to the gamelist.
    I tried to remap my controller. CONTROLLERS SETTINGS -> CONFIGURE A CONTROLLER -> ecc..
    Everything works perfectly in menus outside the games, but the games don't start! :((
    My controller is a PS3 Shaman Xtreme 90304 (a clone of the original PS3 controller). This controller works perfectly with the stable version 18.07.13

  • Staff

    @maxmoro77 What hardware? What emulator? What game?
    There nothing more useless than a: "it doesn"t work"!

  • @bkg2k said in February 2019 Beta Version:

    @maxmoro77 What hardware? What emulator? What game?
    There nothing more useless than a: "it doesn"t work"!

    It's a Rasperry Pi 3B+, I only tried the games already included with recalbox. No game works.

  • Staff

    @maxmoro77 Ok, that's more useful ;)
    Can you check, while remapping your PS3 pad, that no "axis" appear in L/R/L2/R2/L3/R3 ?

  • @bkg2k said in February 2019 Beta Version:

    no "axis" appear in L/R/L2/R2/L3/R3 ?

    No, no "axis" appear in L/R ecc..
    only correct BUTTON 4, 5, 6, 7, ecc...
    I know how to access via ssh to my rpi3b+ if I can help.

  • Wow, Nice beta update! a lot of stuff to test.
    Congrats guys!

  • Other bug for me, when I restart recalbox, the pad is no longer paired with the Rpi bluetooth. I must reconnect via usb, pair again and remap.... but the games no works.

  • Staff

    @maxmoro77 support archive please.

  • I have a bug.
    Using a PC x64 version. I can't open kodi. when I start it up it black screens and then back to recalbox.

  • @acris said in February 2019 Beta Version:

    @maxmoro77 support archive please.

    I'm so sorry! I reflash my sd card and now... All work! O_O My joypad works. In next days I will try all. Thanks for now, and sorry again.

  • @yougi8000 J'ai vérifié sur mon PI3+ avec ma version SD V2018.12.24.CHRISTMAS.BETA, mes jeux PSP se lancent bien. Il s'agit bien donc d'un nouveau problème de cette version beta de février 2019.

  • Salut. Super boulot les mecs, vous avez bossés comme des mutants ! Bravo.

    Petits retours de ma version sur Pi 3b avec roms sur USB :

    • L'amiga 600 crash systématique. Il semblerait que la config prends une ROM 1.2 avec du full ECS et amiga 600. Si je sélectionne à la main une ROM 2.0, ça repart (logique :) )

    • J'ai testé quelques WHD, certains refusent de se lancer : "Volume DH0 is write protected". Rencontré sur Eliminator, Jim power, Giana sister SE pour l'instant, (je les ai compressés en ZIP) ... Pas d'explication :/

    J'ai remarqué qu'il n'y a plus d'écriture des scores, je suppose qu'on ne peut y remédier ? SNIF

    Mais encore BRAVO pour le travail abattu, Recalbox reste la distrib la plus aboutie à ce jour, et haut la main.

    Chapeau bas

  • @Bkg2k
    Thanks a lot to all dev team and to Bkg2k.

    Board : XU4
    Image : Feb 2019
    Micro SD card
    No USB Stock
    Pad a : Wired GameStop PS4 Fun Controller
    BT Controller : CSL - V4.0 USB nano Adaptateur Bluetooth avec DEL Class 4.0
    Pad b : 8bitdo SF30 Pro

    Archive support if can help : https://file.ac/CwR70QzkxB0/

    Issues with BT on 8bitdo pad.
    On the 1st boot, very difficult. So I clear and reset all BT connection on XU4, reset the pad. Then I reboot the XU4.
    I manage to pair the 8bitdo with ES. So I remapp all controls boutons.
    After a re start of Xu4, I start my 8bitdo controller with "B+Start"
    I received a viration on the pad and the led stop flasing.
    But unfortunatly no control boutonsn works ...

    I will try using 'Méthode 2b' with bluetoothctl explained here

    Issue solved with using correct driver 'BLUEZ 5' and not 'OFFICIAL'
    Please disregard this message

  • Hi guys!
    Bug report :
    Kodi failed to launch when using an external drive (black screen goes back to ES).
    Works fine when not using USB external drive.

    Conf Detail :
    RPI 3b
    Bartop - 2 Dragonrise Inc. compatible joysticks with USB interface
    22 inch Full HD screen - HDMI 2 VGA adapter (1080p conf)
    Clean February Beta Update version on a 64G SD card with echer
    No roms loaded on SD cards
    External 128 G Usb Key containing most of the systems.


  • Staff

    @maxmoro77 Great! Hope tht everything will run fine for you now :)

  • Staff

    @nordicpower Oui il y a un soucis avec la PSP comme noté dans les known bugs. Les images Pi3/XU4 et x86 seront remise à jour bientôt pour corriger la librairie manquante.

  • @Bkg2k
    Board : both XU4 and RPI3B
    No theme
    Only Micro SD Card, No USB Stick
    With correct Bios dc_flash MDR5 d6e11a23f1fa01cddb5dfccf7e4cc8d7 and / or 23df18aa53c8b30784cd9a84e061d008
    impossible to adjust date setting and go to valid bouton "Selection"


  • @Bkg2k
    Board XU4
    No theme
    Only Micro SD Card, No USB Stick
    N64 issue with BT pads inside game menu

    With BT 8bitdo set as primary pad
    With Wired GameStop PS4 Fun Controller set as secondary pad
    In the games Mario Kart 64 (E) (V1.1) [!].z64 & RR64 - Ridge Racer 64 (Europe).z64
    Inside game menu, get stopped with BT 8bitdo pad. Pad does not allow to move or perform any action.
    The only way to move is to use the wired pad

  • Hey, guys!

    I think the NeoGeoCD system doesn't load audio tracks properly. I've focused on the game Metal Slug (World) and WindJammers (World) in cue + img (truerip) format. After setting the correct bios, the game loads correctly, but when it comes to playing the music doesn't do it correctly. With IsoBuster, I changed the format from cue + img to bin + cue and iso + cue. In all cases, it does the same thing: it loads the game well, but not the music tracks.

    To rule out misconfiguration problems on my part, I downloaded retroarch 1.7.6 for Windows with free fba core. In this scenario, (same rom and same bios as with rpi3) I can load the game and the music works perfectly.

    Have you been able to make the audio tracks sound correctly with NeoGeo CD? Am I missing anything?


    My Hardware:
    Rpi3 without overclock
    Default theme
    8bitdo SF30 Pro
    BIOS used: neogeo.zip and neocdz.zip in the neogeocd folder.

  • Hello,

    Super version que cette dernière bêta!
    J'ai testé les 3 et on voit bien tout le boulot qui a été fait, même si je n'ai pas fini de tester tous les émulateurs. En tout cas le safe shutdown marche.
    En revanche, il y a ce même problème depuis le début : la connexion au wifi en 5G (ac) ne fonctionne pas, ça accroche parfois mais ça ne tient pas, même en redémarrant.

    J'ai lu certains commentaires sur les précédentes releases qui parlaient de ce même problème.
    Quelqu'un a-t-il une idée de résolution ou est-ce simplement un bug connu à cette étape de la bêta ?

    PS : concernant la dreamcast, sur Retropie on doit remapper les boutons à partir du terminal via un script spécial pour pouvoir passer l'écran de l'horloge et jouer, peut-être est-ce la même chose ici ?

    Great bêta and the work since the first is enormous! And the safe shutdown is working.
    But it seems there is a bug with the 5G wifi (ac), even after reboot. I had read that others members had the same problem on the previous bêta.
    Is it a known bug ? Any solution ?

    PS : for the dreamcast, on Retropie we have to remap the pad through the terminal with a special script to access the time screen and play, maybe it is the same thing here ?


    RPi 3b+ sans O/C
    Micro SD Sandisk Ultra 128 Go
    8bitdo SF30 Pro

Log in to reply

Want to support us ?

Join us on :





Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.