Recalbox 7.0

8Bitdo SF30 PRO pairing lost



  • Hi guys,

    As I've tried everything I found at the forum and also Google, I have to ask for your help and experiences:

    My 8Bitdo SF30 PRO works like a charm after pairing, but when I reboot Recalbox, it will not connect with my Pi anymore. Sometimes already after first reboot, sometimes after 10 reboots.
    I have to delete all bluetooth configuration and pair it again when this happens. I use "forget all bluetooth controllers" in EmulationStation and also delete the tar-file where paired bluetooth devices are stored, that's the only way that allows me pairing this controller again.

    I'm using latest stable version of Recalbox.

    I've tried almost everything:

    • Tried internal bluetooth (instead of dongle with CSR bluetooth chipset)
    • Paired controller both in Switch- and Android-Mode, where controller seem to work fine (Windows and Mac modes seem to have issues, in Windows-mode L2-R2 buttons won't work, in Mac-mode no button, stick and d-pad will work at all).
    • Paired using shell (bluetoothctl) - Pairing worked, but same issue afterwards
    • Switch controller on only when EmulationStation is loaded already
    • Did a complete fresh install of latest Recalbox stable

    I can exclude any hardware issue on Pi-side, because I have paired many bluetooth devices and none of them has this problem (8Bitdo N30 PRO controller, Playstation 4 controller, Logitech keyboard, Microsoft mouse)

    Because of 8Bitdo SF30 PRO is the best controller I've ever tried for retro gaming, I would appreciate if you have a hint or solution for me!

    Thanks to all in advance!


  • Local Moderator
    Tester

    Hi, i'm using a 8Bitdo SF30 Pro pad, and it works fine on both RPi3b with the last RecalboxOS & RPi3b+ with the beta version.
    To use the bluetooth, you MUST use the d-input mode (start+B). To appair the pad, see the manual : switch on the pad by using the "start"+"B" buttons, the first light will flash, then press the pairing button 3 seconds. A chaining light starts. Then, through the ES, launch a search for bluetooth pads. Your pad will be detected, appair it.
    When you switch off your Rpi, or simply relaunch your OS, your SF30 won't be detected if you haven't switch it off first. If it was switch on when rebooting for example, switch it off (by pressing start 3 seconds), then switch it on (by simply press start, don't press "B" this time), wait 2 or 3 seconds, your pad will shock to announce its connected. Use it & play 😉
    X-input is used for windows, macOS for mac, Y-input for Nintendo Switch. D-input is also used for Android.
    Take care if you use the pad with several hardwares (like me, for example on my PC and my recalbox). The last BT connection is used by default. Simply shut down one BT connection to activate the other ^^
    Regards.



  • @scavy
    Hi, thanks for answer, but it's exactly the way I tried (next to other ways I described):

    "Android-Mode" = "d-input" = Start+B

    And I also know that I have to switch off the gamepad and switch it on again when I reboot - Same way I do it with my other working 8Bitdo pad, the (older) 8Bitdo N30 PRO!

    My problem is, that the pad just does NOT connect anymore after reboot, even though I switch it off and on again, stay in mode "d-input" and even don't connect it to other devices, just to Pi/Recalbox. First LED keeps flashing instead of staying just on and no shock feedback as usual.

    Maybe you have another idea? If it works on your side, maybe I got a defective one... 😞 I've already sent it back to Amazon, in the meanwhile. Maybe I'll give it another try with a new one...


  • Local Moderator
    Tester

    @lhari84 If it was correctly configurated, i don't have any idea about the root of the problem. In any case, the pad works well at home. Maybe yours is defective, who knows ? I also bought it to Amazon 😉
    Good luck



  • @scavy
    In the meanwhile tried 8bitdo N30 pro 2, which results in exactly the same problem. So in my point of view, latest stable of Recalbox has a problem with new 8bitdo controllers, maybe all those already have a USB-C port. Maybe some new controller/chip/firmware modification in these devices...
    No idea why it works on your side still. Maybe also a interferrence with WIFI that destroys the pairing - I don't know.

    Gave it up and waiting for all new Recalbox Pi 3 B+ final version...

    In the meanwhile I'm using this new guy I freshly ordered too, with a Wii Classic controller connected. It's working like a charm...

    0_1545385172246_2018-12-21_103624.jpg

    ...without loosing the pairing - And, though it's new on the market, it has an old, non-USB-C connector. That's also why I think there was some modification in latest 8bitdo hardware, that doesn't want to keep keep paired smoothly with latest RB stable!


  • Local Moderator
    Tester

    @lhari84 Nice new pad 🙂
    I can't explain why it's working at home and not with your system. If there's people using our 8bitdo SF30 pro pad reading this topic, please let us know if it's working well or not, thanx !



  • @scavy I'm also using the SF30 Pro with the last beta. Not experiencing any issues with it.
    Though I don't think I have done 10 reboots yet after pairing it. Maybe 5 times, it's still working.

    Maybe this is related to different firmware versions? If I recall correctly, I only updated it once immediately after buying it, and I bought it close to the original release date.


  • Local Moderator
    Tester

    @bloodsurfer yeap, it's a possibility. My pad is quite recent too. Ihari84, did you update your pad's firmware ?



  • @scavy Unfortunately I have to report also the 8bitdo G Bros adaper (from picture above) sucked after few reboots in the meanwhile.
    Seems it‘s only working with my old, legacy 8bitdo N30 Pro and Sony DualShock 4 controller then 😞

    All newer 8bitdo I tried faced this problem so far (SF30 Pro, N30 Pro 2 and G Bros adapter)!
    Each I flashed with latest firmware before pairing.



  • It could also be related to some different setting in recalbox.conf. How is your config? Which BT driver are you using for example?

    controllers.ps3.enabled=1
    controllers.ps3.driver=bluez
    controllers.xboxdrv.enabled=0
    controllers.xboxdrv.nbcontrols=2
    controllers.gpio.enabled=0
    controllers.gpio.args=map=1,2
    controllers.db9.enabled=0
    controllers.db9.args=map=1
    controllers.gamecon.enabled=0
    controllers.gamecon.args=map=1
    controllers.xarcade.enabled=1



  • @bloodsurfer
    Here my config. Have to say I‘ve changed nothing. It‘s everthing from fresh, clean install of latest Recalbox stable:

    **# -------------- D - Controllers ----------------- #

    Enable support for standard bluetooth controllers

    controllers.bluetooth.enabled=1

    Please enable only one of these

    -------------- D1 - PS3 Controllers ------------

    ##Enable PS3 controllers support
    controllers.ps3.enabled=1

    Choose a driver between bluez, official and shanwan

    bluez -> bluez 5 + kernel drivers, support official and shanwan sisaxis

    official -> sixad drivers, support official and gasia sisaxis

    shanwan -> shanwan drivers, support official and shanwan sisaxis

    controllers.ps3.driver=bluez

    ------------ D2 - GPIO Controllers ------------

    GPIO Controllers

    enable controllers on GPIO with mk_arcarde_joystick_rpi (0,1)

    controllers.gpio.enabled=0

    mk_gpio arguments, map=1 for one controller, map=1,2 for 2 (map=1,map=1,2)

    controllers.gpio.args=map=1,2

    ------------ D3 - Steam Controllers ------------

    Enable steam controller service

    controllers.steam.enabled=0

    DB9 Controllers

    Enable DB9 drivers for atari, megadrive, amiga controllers (0,1)

    controllers.db9.enabled=0

    db9 arguments

    controllers.db9.args=map=1

    Gamecon controllers

    Enable gamecon controllers, for nes, snes psx (0,1)

    controllers.gamecon.enabled=0

    gamecon_args

    controllers.gamecon.args=map=1

    XGaming's XArcade Tankstik and other compatible devices

    controllers.xarcade.enabled=1**

    Do you have any suggestions what I could change to make these newer 8bitdo controllers staying paired?



  • @lhari84
    P.S.: I don‘t think changing driver in recalbox.conf is a solution. Seems it‘s, as the name of switch already says, for PS3 pads only:
    https://github.com/recalbox/recalbox-os/wiki/PS3-controllers-drivers-(EN)

    Any other setting I could give a try?



  • @lhari84 the same is happening to me, after rebooting or powering off, I lose the pairing on my SF30 Pro 😞 I am using the latest 8bitdo firmware available (1.29).

    Starting SF30 Pro by start+B. The only way to make It connect again is to forget bluetooth controllers an pair It again, so I need a usb-c or another USB controller to pair it again.

    Any ideas?



  • @foxzflow
    Are you using a Bluetooth dongle or internal bluetooth? If donlge, do you know which chipset it has? (CSR or Broadcom?)
    I‘m using CSR based dongle in Pi3 B. And I have not tried internal Bluetooth, because it sucks on Pi3 B, way too much input lag.

    These problems seem to be gone with Pi3 B+. In latest christmas beta, pairing of latest 8bitdo controllers do not get lost and no input lag there with it‘s internal bluetooth. But this beta brings other problems, that‘s why I stick on latest stable and the „old“ Pi3 B 😞 Hope there is a stable, final version soon...

    Further I can‘t understand why so less people seem to have this reproducible issue. Maybe it‘s because this forum is visited mostly by french people who don‘t care about english/international posts. -> Same in beta-thread, most communication is french and my english posts seem to be ignored. Even though in first post moderator wrote communication should be in english, so as many people as possible can contribute... I know, Google translator could help, and so on... but in the end it’s a bit annoying and much information gets lost!



  • I am using an external bluetooth dongle (CSL - USB nano Bluetooth V4.0) but I am not quite sure if it has CSR or Broadcom chipset. I did some research and found that chipset can be CSR 8510 A10 but not 100% sure.

    Anyway I am not using internal bluetooth as my board is an Odroid XU4 that does not have builtin bluetooth, so I had to buy external dongle.

    I have not tried the latest christmas beta yet, I think I will also stick on the current stable version and I will wait for the next stable one as this is a minor problem for me.

    Thanks for your help, lets see if the problem is gone on the next release 🙂



  • @foxzflow
    CSL should use CSR chipset, I‘m using the same! Before I tried a Digitus dongle, also CSR. As it didn‘t fit in Superpi case because of its size, I removed housing of both and both modules look quite similiar, just the CSL has a very bright LED compared to the Digitus 😉 Also MAC adress tells me it‘s from the same Chinese manufacturer.

    I also tried an Asus dongle with Broadcom chipset, but here I had same problem like with Pi3 B‘s internal Broadcom chipset: Inputs where much too sensitive, for example at steering at Mario Kart.

    But as discussed, also tried with internal Broadcom chipset of Pi3 B+ in beta and there it seems work fine. (Not too sensitive and also no known input lag of Pi3 B)
    So I hope there is a final version for B+ soon too. I‘m really looking forward because for me there is no real alternative to the really good, new 8bitdo controllers!



Want to support us ?

111
Online

79.1k
Users

20.4k
Topics

149.2k
Posts