MSX emulation not working bluemsx or fmsx on 18.07.13 fresh install



  • I have searched this issue on the forum, and found people saying that there is an issue with BlueMSX on Recalbox and that you can use fMSX in the meantime. However, I try both, and both don't work. And yes, I obtained the Databases/Machines folder from BlueMSX and placed it in the appropriate folder, and did the same with the ROMs for the fMSX version. On a much older version of Recalbox, those steps actually work, but on this version it doesn't.

    I run Recalbox on an Intel NUC with i3 CPU, installed on the HDD (used Etcher to write the image directly to harddrive connected with USB dock, then unplugged drive and put it in the Intel NUC - it boots fine, other emulation stuff works fine too).

    I tried BlueMSX and fMSX. BlueMSX just blanks my screen for a second, then returns to the menu, when I try to start a game. fMSX gives me the blue boot screen for MSX, then the black MSX logo comes up, but distorted and corrupted, and then the emulated machine just hangs. The only thing I can do is press escape on my keyboard and return to the menu again.

    This is a fresh install of Recalbox 18.07.13, no settings altered, and only the BIOSes added so BlueMSX and fMSX should work, but don't.

    Anyone have any tips on getting it to work with at least fMSX?

    ps: since I can't find where to download the BIOS for fMSX I found them here, I hope this is the correct source:
    https://github.com/libretro/fmsx-libretro/tree/master/fMSX/ROMs



  • @novaflash Have you been able to fix this issue? I am experiencing the same issue, even the latest Recalbox 6. Can you tell me how you resolved it? Thanks!


  • Staff
    Developer
    Team
    Global moderator
    Translator

    @samba add the bios files like indicated in the readme inside the rom folders.



Want to support us ?

310
Online

81.4k
Users

22.2k
Topics

161.4k
Posts