Cannot launch PSX titles.

  • Hey guys,

    So I'm trying to use Recalbox over SMB from a NAS. Everything is working fine except PSX.

    I've run the same titles with the same BIOS files with Batocera previously, and everything worked fine, however that was local instead of over the network.

    But basically when I launch a PSX title over the SMB share, the screen goes black (expected) and my network switch goes crazy while it loads (expected) and then the switch goes quiet. About a second later I get thrown back to the PSX menu.

    I've tried different titles, including a 53MB title as apposed to the average ~300-400MB titles, I've tried making sure the file has no spaces, different extensions and removing the BIOS directory from the SMB share completely and using local storage for BIOS binaries. No luck.

    No matter what I do, I cannot get PSX titles to load. 😞

    Any help would be awesome, no idea what to try. Again I don't think this is a BIOS or ROM issue. They worked fine before.


  • Changed engine core to pcsx_rearmed and it's fixed!

Want to support us ?