Raspberry Pi 4

For information, Recalbox IS NOT compatible with Raspberry Pi 4 yet.
Pour information, Recalbox N'EST PAS encore compatible avec le Raspberry Pi 4.

The Recalbox Team.

Cannot get anything to run in dosbox


  • Banned

    @aintmichael
    I am not sure, it is the reason. You have in your dosbox.cfg the name of the mapper file as :
    mapperfile=mapper-0.74.map
    Try perhaps to limit to 8 characters and no special. Best give it the same name as your folder .pc as otrail.map for example. Anyway if they all have the same name you will never find them back.



  • I'll give that a try. I'm also trying another pi, I have a 1 a 2 and a 3, i tried the 1 and the 2, now I'm trying the 3.


  • Banned

    @aintmichael
    but always with the appropriated PI version of Recalbox, I suppose.



  • @Dragu Yup. i've even redownloaded each version just to make sure i was getting a good solid copy for each



  • So the mapper file change on the pi 2 didn't work.

    I just set up the pi3 though and it worked as expected. Just put the same folder and a .bat with just oregon.exe. so the only difference I can see is which version of the pi I used. Is there some inherent difference in the installs for each of the versions?


  • Banned

    @aintmichael
    You have still an easy option to see what happens.
    Try to rename or delete momentary dosbox.bat. If you start after the game from ES, you will land on Z: . Now you must mount C.
    mount c /recalbox/share/roms/dos/otrail.pc
    c:
    Making dir, you should see your files. And after try to start the game with OREGON.EXE
    Minimum you should get an error.



  • So if i rename dosbox.bat on the pi2 it still just pops open for a second then goes away. Basically the exact same thing as with all the other changes. It does behave the way you are saying on the pi 3 however.


  • Banned

    @aintmichael
    Astonishing, because this would mean that dosbox is not running correctly on PI <3.
    And like I have no lower as PI3 or CM3, so I cannot test. On PI Zero (that I also dont have) it should run. But anyway, PI1, Pi2 is today crappware ;)



  • Yeah... so just to close this off. Still not running on the Pi 2 or 1, but since I need to build 6 of these I just ordered a bunch of 3's. Was hoping to use up this older hardware. I appreciate the help @Dragu and @voljega. Most of the other emulators worked on at least the pi 2, except some problems with mame that I quickly gave up on. So for the future people's who may come across this: Never got Dos emulation working on pi 1 or 2, so if you're trying on one and find this post... get at least a 3 I guess.


  • Banned

    @aintmichael
    There is still one option staying, to replace the dosbox version in the packages with an older one, working pretty well for me and that I use currently. As /usr/bin/dosbox
    Older Dosbox version



Want to support us ?

Join us on :

254
Online

48461
Users

17583
Topics

132489
Posts

Looks like your connection to Recalbox Forum was lost, please wait while we try to reconnect.